introduce a menuconfig option to turn off static linking of host utilities
[openwrt/openwrt.git] / include / host-build.mk
index a8bc79ea67de34648d444644e694539b8d95d219..40af5c87ccfa703d3030603f88a87b1d534744fd 100644 (file)
@@ -66,7 +66,9 @@ HOST_CONFIGURE_ARGS = \
 HOST_CONFIGURE_CMD = ./configure
 
 ifneq ($(HOST_OS),Darwin)
-  HOST_STATIC_LINKING = -static
+  ifeq ($(CONFIG_BUILD_STATIC_TOOLS),y)
+    HOST_STATIC_LINKING = -static
+  endif
 endif
 
 define Host/Configure/Default