same for host builds
[openwrt/openwrt.git] / include / host-build.mk
index 591a36bd383729f0afe32d741d3c89a50a1b346c..e934c91c66d9b94d068f84e81f236993669baea3 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,16 +9,18 @@ include $(INCLUDE_DIR)/host.mk
 include $(INCLUDE_DIR)/unpack.mk
 include $(INCLUDE_DIR)/depends.mk
 
-STAMP_PREPARED=$(PKG_BUILD_DIR)/.prepared
-STAMP_CONFIGURED=$(PKG_BUILD_DIR)/.configured
-STAMP_BUILT=$(PKG_BUILD_DIR)/.built
+STAMP_PREPARED:=$(PKG_BUILD_DIR)/.prepared_$(shell find ${CURDIR} $(PKG_FILE_DEPEND) $(DEP_FINDPARAMS) | md5s)
+STAMP_CONFIGURED:=$(PKG_BUILD_DIR)/.configured
+STAMP_BUILT:=$(PKG_BUILD_DIR)/.built
+override MAKEFLAGS=
 
+include $(INCLUDE_DIR)/quilt.mk
+
+Build/Patch:=$(Build/Patch/Default)
 ifneq ($(strip $(PKG_UNPACK)),)
   define Build/Prepare/Default
        $(PKG_UNPACK)
-       @if [ -d ./patches ]; then \
-               $(PATCH) $(PKG_BUILD_DIR) ./patches; \
-       fi
+       $(Build/Patch)
   endef
 endif
 
@@ -29,6 +31,7 @@ endef
 define Build/Configure/Default
        @(cd $(PKG_BUILD_DIR)/$(3); \
        [ -x configure ] && \
+               $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/$(3)/ && \
                $(2) \
                CPPFLAGS="-I$(STAGING_DIR)/host/include" \
                LDFLAGS="-L$(STAGING_DIR)/host/lib" \
@@ -80,8 +83,8 @@ endif
 ifneq ($(CONFIG_AUTOREBUILD),)
   define HostBuild/Autoclean
     $(PKG_BUILD_DIR)/.dep_files: $(STAMP_PREPARED)
-    $(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(STAMP_PREPARED),$(TMP_DIR)/.packagedir_$(shell echo "${CURDIR}" | md5s))
-    $(call rdep,$(PKG_BUILD_DIR),$(STAMP_BUILT),$(PKG_BUILD_DIR)/.dep_files, -and -not -path "/.*" -and -not -path "*/ipkg*")
+    $(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(STAMP_PREPARED))
+    $(if $(filter prepare,$(MAKECMDGOALS)),,$(call rdep,$(PKG_BUILD_DIR),$(STAMP_BUILT),$(PKG_BUILD_DIR)/.dep_files, -and -not -path "/.*" -and -not -path "*/ipkg*"))
   endef
 endif