ubifs: enable building modular images
[openwrt/openwrt.git] / include / host.mk
index 9b8a32b672d3579c5cbe1deed2f7625dec912e0a..000fb1898475270eb533d833e5012ecdfd3e50bd 100644 (file)
@@ -54,14 +54,12 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
                else \
                        echo "FIND_L=$$FIND \$$(1) -follow" >> $@; \
                fi; \
-               if xargs --help 2>&1 | grep 'gnu.org' >/dev/null; then \
-                       echo 'XARGS:=xargs -r' >> $@; \
-               else \
-                       echo 'XARGS:=xargs' >> $@; \
-               fi; \
                PATCH=`which gpatch 2>/dev/null`; \
                [ -n "$$PATCH" -a -x "$$PATCH" ] || PATCH=`which patch 2>/dev/null`; \
                echo "PATCH:=$$PATCH" >> $@; \
+               PYTHON=`which python2.7 2>/dev/null`; \
+               [ -n "$$PYTHON" -a -x "$$PYTHON" ] || PYTHON=`which python 2>/dev/null`; \
+               echo "PYTHON:=$$PYTHON" >> $@; \
        )
 
 endif