kernel: update 4.1 to 4.1.4
[openwrt/openwrt.git] / include / host.mk
index 02365d9eabdf074a35c6cccc20eeb9bf8709ffd0..ec3ae276a429809acefa78ff4a719ea0ee7ff335 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007-2010 OpenWrt.org
+#
+# Copyright (C) 2007-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,11 +10,11 @@ ifeq ($(if $(TARGET_BUILD),,$(DUMP)),)
   -include $(TMP_DIR)/.host.mk
 endif
 
-export TAR FIND
-
 ifneq ($(__host_inc),1)
 __host_inc:=1
 
+export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH)
+
 try-run = $(shell set -e; \
        TMP_F="$(TMP_DIR)/try-run.$$$$.tmp"; \
        if ($(1)) >/dev/null 2>&1; then echo "$(2)"; else echo "$(3)"; fi; \
@@ -32,32 +32,20 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
                HOST_OS=`uname`; \
                case "$$HOST_OS" in \
                        Linux) HOST_ARCH=`uname -m`;; \
+                       Darwin) HOST_ARCH=`uname -m`;; \
                        *) HOST_ARCH=`uname -p`;; \
                esac; \
                GNU_HOST_NAME=`gcc -dumpmachine`; \
-               [ -n "$$GNU_HOST_NAME" ] || \
-                       GNU_HOST_NAME=`$(SCRIPT_DIR)/config.guess`; \
+               [ -z "$$GNU_HOST_NAME" -o "$$HOST_OS" = "Darwin" ] && \
+                       GNU_HOST_NAME=`$(TOPDIR)/scripts/config.guess`; \
                echo "HOST_OS:=$$HOST_OS" > $@; \
                echo "HOST_ARCH:=$$HOST_ARCH" >> $@; \
                echo "GNU_HOST_NAME:=$$GNU_HOST_NAME" >> $@; \
-               TAR=`which gtar 2>/dev/null`; \
-               [ -n "$$TAR" -a -x "$$TAR" ] || TAR=`which gnutar 2>/dev/null`; \
-               [ -n "$$TAR" -a -x "$$TAR" ] || TAR=`which tar 2>/dev/null`; \
-               echo "TAR:=$$TAR" >> $@; \
-               FIND=`which gfind 2>/dev/null`; \
-               [ -n "$$FIND" -a -x "$$FIND" ] || FIND=`which find 2>/dev/null`; \
-               echo "FIND:=$$FIND" >> $@; \
-               echo "BASH:=$(shell which bash)" >> $@; \
-               if $$FIND -L /tmp -maxdepth 0 >/dev/null 2>/dev/null; then \
-                       echo "FIND_L=$$FIND -L \$$(1)" >>$@; \
-               else \
-                       echo "FIND_L=$$FIND \$$(1) -follow" >> $@; \
-               fi; \
-               if xargs --help 2>&1 | grep 'gnu.org' >/dev/null; then \
-                       echo 'XARGS:=xargs -r' >> $@; \
+               if gfind -L /dev/null || find -L /dev/null; then \
+                       echo "FIND_L=find -L \$$(1)" >> $@; \
                else \
-                       echo 'XARGS:=xargs' >> $@; \
-               fi; \
-       )
+                       echo "FIND_L=find \$$(1) -follow" >> $@; \
+               fi \
+       ) >/dev/null 2>/dev/null
 
 endif