include: remove 34k distinction
[openwrt/openwrt.git] / include / host.mk
index 6c0dcd6699f39d2202d396b6b45fb77838cf4ea9..ec3ae276a429809acefa78ff4a719ea0ee7ff335 100644 (file)
@@ -1,35 +1,51 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2007-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
-include $(TOPDIR)/.host.mk
+TMP_DIR ?= $(TOPDIR)/tmp
+ifeq ($(if $(TARGET_BUILD),,$(DUMP)),)
+  -include $(TMP_DIR)/.host.mk
+endif
+
+ifneq ($(__host_inc),1)
+__host_inc:=1
+
+export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH)
+
+try-run = $(shell set -e; \
+       TMP_F="$(TMP_DIR)/try-run.$$$$.tmp"; \
+       if ($(1)) >/dev/null 2>&1; then echo "$(2)"; else echo "$(3)"; fi; \
+       rm -f "$$TMP_F"; \
+)
 
-export TAR
+host-cc-option = $(call try-run, \
+       $(HOSTCC) $(HOST_CFLAGS) $(1) -c -xc /dev/null -o "$$TMP_F",$(1),$(2) \
+)
 
-$(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
+.PRECIOUS: $(TMP_DIR)/.host.mk
+$(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
+       @mkdir -p $(TMP_DIR)
        @( \
                HOST_OS=`uname`; \
                case "$$HOST_OS" in \
                        Linux) HOST_ARCH=`uname -m`;; \
+                       Darwin) HOST_ARCH=`uname -m`;; \
                        *) HOST_ARCH=`uname -p`;; \
                esac; \
                GNU_HOST_NAME=`gcc -dumpmachine`; \
-               [ -n "$$GNU_HOST_NAME" ] || \
-                       GNU_HOST_NAME=`$(SCRIPT_DIR)/config.guess`; \
+               [ -z "$$GNU_HOST_NAME" -o "$$HOST_OS" = "Darwin" ] && \
+                       GNU_HOST_NAME=`$(TOPDIR)/scripts/config.guess`; \
                echo "HOST_OS:=$$HOST_OS" > $@; \
                echo "HOST_ARCH:=$$HOST_ARCH" >> $@; \
                echo "GNU_HOST_NAME:=$$GNU_HOST_NAME" >> $@; \
-               TAR=`which gtar`; \
-               [ -n "$$TAR" -a -x "$$TAR" ] || TAR=`which tar`; \
-               echo "TAR:=$$TAR" >> $@; \
-               if $$TAR --version 2>&1 | grep 'GNU' >/dev/null; then \
-                       echo "TAR_WILDCARDS:=--wildcards" >> $@; \
-               fi; \
-               ZCAT=`which gzcat`; \
-               [ -n "$$ZCAT" -a -x "$$ZCAT" ] || ZCAT=`which zcat`; \
-               echo "ZCAT:=$$ZCAT" >> $@; \
-       )
+               if gfind -L /dev/null || find -L /dev/null; then \
+                       echo "FIND_L=find -L \$$(1)" >> $@; \
+               else \
+                       echo "FIND_L=find \$$(1) -follow" >> $@; \
+               fi \
+       ) >/dev/null 2>/dev/null
 
+endif