build: avoid failing in append-metadata if image could not be generated
[openwrt/openwrt.git] / include / image-commands.mk
index 1ec5252972c3a012c9bef782133fedb41af78b58..8db046bdea6a928be6152de5b69046b18a02711b 100644 (file)
@@ -281,7 +281,7 @@ metadata_json = \
        }'
 
 define Build/append-metadata
-       $(if $(SUPPORTED_DEVICES),echo $(call metadata_json,$(SUPPORTED_DEVICES)) | fwtool -I - $@)
+       $(if $(SUPPORTED_DEVICES),-echo $(call metadata_json,$(SUPPORTED_DEVICES)) | fwtool -I - $@)
 endef
 
 define Build/kernel2minor