build: unsilence move command
[openwrt/openwrt.git] / include / image-commands.mk
index 7d124ece19baa2a4f47ac7b650e9b975ce806363..c513f19d3a1244ae2d6cd692b0f2545b393bda1c 100644 (file)
@@ -8,7 +8,7 @@ define Build/uImage
                -O linux -T kernel \
                -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
                -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) LEDE Linux-$(LINUX_VERSION))' -d $@ $@.new
-       @mv $@.new $@
+       mv $@.new $@
 endef
 
 define Build/buffalo-enc
@@ -62,6 +62,18 @@ define Build/netgear-dni
        mv $@.new $@
 endef
 
+# append a fake/empty rootfs uImage header, to fool the bootloaders
+# rootfs integrity check
+define Build/append-uImage-fakeroot-hdr
+       rm -f $@.fakeroot
+       $(STAGING_DIR_HOST)/bin/mkimage \
+               -A $(LINUX_KARCH) -O linux -T filesystem -C none \
+               -n '$(call toupper,$(LINUX_KARCH)) LEDE fakeroot' \
+               -s \
+               $@.fakeroot
+       cat $@.fakeroot >> $@
+endef
+
 define Build/tplink-safeloader
        -$(STAGING_DIR_HOST)/bin/tplink-safeloader \
                -B $(TPLINK_BOARD_NAME) \
@@ -143,10 +155,6 @@ define Build/append-rootfs
        dd if=$(IMAGE_ROOTFS) >> $@
 endef
 
-define Build/append-file
-       cat "$(1)" >> "$@"
-endef
-
 define Build/append-ubi
        sh $(TOPDIR)/scripts/ubinize-image.sh \
                $(if $(UBOOTENV_IN_UBI),--uboot-env) \