image.mk: add support for specifying the VID header offset for UBI
[openwrt/openwrt.git] / include / image-commands.mk
index 1128aeab6d8b1a0a40652fe170ed2f4d73373306..fc36509efd604f9f1ffebb9f45fc4a53eedc2d07 100644 (file)
@@ -107,6 +107,7 @@ define Build/append-ubi
                $@.tmp \
                -p $(BLOCKSIZE) -m $(PAGESIZE) \
                $(if $(SUBPAGESIZE),-s $(SUBPAGESIZE)) \
+               $(if $(VID_HDR_OFFSET),-O $(VID_HDR_OFFSET)) \
                $(UBINIZE_OPTS)
        cat $@.tmp >> $@
        rm $@.tmp