build: remove harmful -nopad option from mksquashfs
[openwrt/openwrt.git] / include / image.mk
index 5d54bc7947e692dacd7b4e4e2e845b0e824bfc30..599adfaa1072133670139efdf110172c45d46803 100644 (file)
@@ -240,7 +240,7 @@ $(eval $(foreach S,$(NAND_BLOCKSIZE),$(call Image/mkfs/jffs2-nand/template,$(S))
 
 define Image/mkfs/squashfs
        $(STAGING_DIR_HOST)/bin/mksquashfs4 $(call mkfs_target_dir,$(1)) $@ \
-               -nopad -noappend -root-owned \
+               -noappend -root-owned \
                -comp $(SQUASHFSCOMP) $(SQUASHFSOPT) \
                -processors 1
 endef