make maxinodes configureable for ext2
[openwrt/openwrt.git] / include / image.mk
index 4f638f026094b2a4bec81bd716921fbc739a246f..ec0512f904ffeb1ff1f003c9ab4636f1947c03c5 100644 (file)
@@ -56,7 +56,7 @@ ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
   E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_FSPART)*1024)))
   
   define Image/mkfs/ext2
-               $(STAGING_DIR)/bin/genext2fs -U -b $(E2SIZE) -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
+               $(STAGING_DIR)/bin/genext2fs -U -b $(E2SIZE) -I $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
                $(call Image/Build,ext2)
   endef
 endif