build: move the SH_FUNC eval to the beginning of the opkg control file build command...
[openwrt/openwrt.git] / include / kernel-build.mk
index 7c5d1fbe9cd5b9a88c759ecfda8dfe5f778e6146..282dc9614ff422d8de7e82fe1b3366e20623b5fb 100644 (file)
@@ -44,6 +44,19 @@ define Download/kernel
   MD5SUM:=$(LINUX_KERNEL_MD5SUM)
 endef
 
+ifdef CONFIG_COLLECT_KERNEL_DEBUG
+  define Kernel/CollectDebug
+       rm -rf $(KERNEL_BUILD_DIR)/debug
+       mkdir -p $(KERNEL_BUILD_DIR)/debug/modules
+       $(CP) $(LINUX_DIR)/vmlinux $(KERNEL_BUILD_DIR)/debug/
+       -$(CP) \
+               $(STAGING_DIR_ROOT)/lib/modules/$(LINUX_VERSION)/* \
+               $(KERNEL_BUILD_DIR)/debug/modules/
+       $(FIND) $(KERNEL_BUILD_DIR)/debug -type f | $(XARGS) $(KERNEL_CROSS)strip --only-keep-debug
+       $(TAR) c -C $(KERNEL_BUILD_DIR) debug | bzip2 -c -9 > $(BIN_DIR)/kernel-debug.tar.bz2
+  endef
+endif
+
 define BuildKernel
   $(if $(QUILT),$(Build/Quilt))
   $(if $(LINUX_SITE),$(call Download,kernel))
@@ -86,6 +99,7 @@ define BuildKernel
 
   $(LINUX_DIR)/.image: $(STAMP_CONFIGURED) $(if $(CONFIG_STRIP_KERNEL_EXPORTS),$(KERNEL_BUILD_DIR)/symtab.h) FORCE
        $(Kernel/CompileImage)
+       $(Kernel/CollectDebug)
        touch $$@
        
   mostlyclean: FORCE
@@ -99,7 +113,7 @@ define BuildKernel
   compile: $(LINUX_DIR)/.modules
        $(MAKE) -C image compile TARGET_BUILD=
 
-  oldconfig menuconfig: $(STAMP_PREPARED) $(STAMP_CHECKED) FORCE
+  oldconfig menuconfig nconfig: $(STAMP_PREPARED) $(STAMP_CHECKED) FORCE
        [ -e "$(LINUX_CONFIG)" ] || touch "$(LINUX_CONFIG)"
        $(LINUX_CONFCMD) > $(LINUX_DIR)/.config
        touch $(LINUX_CONFIG)