port generic and ixp4xx kernel patches to 2.6.27 (compiles except for iptables, but...
[openwrt/openwrt.git] / include / kernel-build.mk
index 82b0bcff27af7e023a11be3a49bf2e73fe82ab72..477c9eeddf4cd11763c795e6a10b74aaeb132091 100644 (file)
@@ -7,14 +7,11 @@
 include $(INCLUDE_DIR)/host.mk
 include $(INCLUDE_DIR)/prereq.mk
 
-ifneq ($(DUMP),1)
-  override MAKEFLAGS=
-endif
-
 ifneq ($(DUMP),1)
   all: compile
 endif
 
+export QUILT=1
 STAMP_PREPARED:=$(LINUX_DIR)/.prepared
 STAMP_CONFIGURED:=$(LINUX_DIR)/.configured
 include $(INCLUDE_DIR)/download.mk
@@ -48,6 +45,7 @@ define Download/kernel
 endef
 
 define BuildKernel
+  $(if $(QUILT),$(Build/Quilt))
   $(if $(LINUX_SITE),$(call Download,kernel))
 
   $(STAMP_PREPARED): $(DL_DIR)/$(LINUX_SOURCE)
@@ -80,26 +78,21 @@ define BuildKernel
        $(MAKE) -C image compile TARGET_BUILD=
 
   oldconfig menuconfig: $(STAMP_PREPARED) FORCE
+       [ -e "$(LINUX_CONFIG)" ] || touch "$(LINUX_CONFIG)"
        $(LINUX_CONFCMD) > $(LINUX_DIR)/.config
-       $(MAKE) -C $(LINUX_DIR) $(KERNEL_MAKEOPTS) $$@
-       $(SCRIPT_DIR)/kconfig.pl '>' $(GENERIC_LINUX_CONFIG) $(LINUX_DIR)/.config > $(LINUX_CONFIG)
+       touch $(LINUX_CONFIG)
+       $(_SINGLE)$(MAKE) -C $(LINUX_DIR) $(KERNEL_MAKEOPTS) $$@
+       $(SCRIPT_DIR)/kconfig.pl '>' $(GENERIC_LINUX_CONFIG) $(LINUX_DIR)/.config > $(if $(LINUX_SUBCONFIG),$(LINUX_SUBCONFIG),$(LINUX_CONFIG))
        $(Kernel/Configure)
 
   install: $(LINUX_DIR)/.image
-       TARGET_BUILD="" $(MAKE) -C image compile install
+       +$(MAKE) -C image compile install TARGET_BUILD=
 
   clean: FORCE
        rm -rf $(KERNEL_BUILD_DIR)
 
-  rebuild: FORCE
-       @$(MAKE) mostlyclean
-       @if [ -f $(LINUX_KERNEL) ]; then \
-               $(MAKE) clean; \
-       fi
-       @$(MAKE) compile
-
   image-prereq:
-       $(SUBMAKE) -s -C image prereq TARGET_BUILD=
+       @+$(NO_TRACE_MAKE) -s -C image prereq TARGET_BUILD=
 
   prereq: image-prereq