large improvement for parallel builds. works without V=99 now and without warnings...
[openwrt/openwrt.git] / include / kernel-build.mk
index 9335e1a0d5a80ed5c7f6989ed4e2a7fe5344cd47..75c2bcf01aacbedcd5699638c5836db28c9037b3 100644 (file)
@@ -7,10 +7,6 @@
 include $(INCLUDE_DIR)/host.mk
 include $(INCLUDE_DIR)/prereq.mk
 
-ifneq ($(DUMP),1)
-  override MAKEFLAGS=
-endif
-
 ifneq ($(DUMP),1)
   all: compile
 endif
@@ -101,7 +97,7 @@ define BuildKernel
        @$(MAKE) compile
 
   image-prereq:
-       $(SUBMAKE) -s -C image prereq TARGET_BUILD=
+       @$(NO_TRACE_MAKE) -s -C image prereq TARGET_BUILD=
 
   prereq: image-prereq