build: include variant name in STAMP_INSTALLED
[openwrt/openwrt.git] / include / kernel-defaults.mk
index 9f4e2cd9ade86f702772ad5ccfe0b9741d85d4c9..24d26308b129b5202afa6bca61fbd3806ea6d916 100644 (file)
@@ -107,7 +107,6 @@ define Kernel/Configure/Default
        echo "# CONFIG_KALLSYMS_EXTRA_PASS is not set" >> $(LINUX_DIR)/.config.target
        echo "# CONFIG_KALLSYMS_ALL is not set" >> $(LINUX_DIR)/.config.target
        echo "# CONFIG_KALLSYMS_UNCOMPRESSED is not set" >> $(LINUX_DIR)/.config.target
-       echo "# CONFIG_KPROBES is not set" >> $(LINUX_DIR)/.config.target
        $(SCRIPT_DIR)/metadata.pl kconfig $(TMP_DIR)/.packageinfo $(TOPDIR)/.config $(KERNEL_PATCHVER) > $(LINUX_DIR)/.config.override
        $(SCRIPT_DIR)/kconfig.pl 'm+' '+' $(LINUX_DIR)/.config.target /dev/null $(LINUX_DIR)/.config.override > $(LINUX_DIR)/.config
        $(call Kernel/SetNoInitramfs)
@@ -127,11 +126,6 @@ endef
 
 OBJCOPY_STRIP = -R .reginfo -R .notes -R .note -R .comment -R .mdebug -R .note.gnu.build-id
 
-# AVR32 uses a non-standard location
-ifeq ($(LINUX_KARCH),avr32)
-IMAGES_DIR:=images
-endif
-
 # AMD64 shares the location with x86
 ifeq ($(LINUX_KARCH),x86_64)
 IMAGES_DIR:=../../x86/boot