package/utils/e2fsprogs: Update to 1.43.3
[openwrt/openwrt.git] / include / kernel.mk
index cbf342a0d2b7244bfa535913bba9fc25755f5009..2721c83d8eddb9750988c7c9c6daf0fff025980a 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2011 OpenWrt.org
+#
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -30,14 +30,12 @@ else
   endif
 
   ifeq ($(TARGET_BUILD),1)
-    PATCH_DIR ?= ./patches$(if $(wildcard ./patches-$(KERNEL_PATCHVER)),-$(KERNEL_PATCHVER))
-    FILES_DIR ?= $(foreach dir,$(wildcard ./files ./files-$(KERNEL_PATCHVER)),"$(dir)")
+    PATCH_DIR ?= $(CURDIR)/patches$(if $(wildcard ./patches-$(KERNEL_PATCHVER)),-$(KERNEL_PATCHVER))
+    FILES_DIR ?= $(foreach dir,$(wildcard $(CURDIR)/files $(CURDIR)/files-$(KERNEL_PATCHVER)),"$(dir)")
   endif
   KERNEL_BUILD_DIR ?= $(BUILD_DIR)/linux-$(BOARD)$(if $(SUBTARGET),_$(SUBTARGET))
   LINUX_DIR ?= $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)
-  ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.7.0)),1)
-    LINUX_UAPI_DIR=uapi/
-  endif
+  LINUX_UAPI_DIR=uapi/
   LINUX_VERMAGIC:=$(strip $(shell cat $(LINUX_DIR)/.vermagic 2>/dev/null))
   LINUX_VERMAGIC:=$(if $(LINUX_VERMAGIC),$(LINUX_VERMAGIC),unknown)
 
@@ -54,7 +52,7 @@ else
   LINUX_SOURCE:=linux-$(LINUX_VERSION).tar.xz
   TESTING:=$(if $(findstring -rc,$(LINUX_VERSION)),/testing,)
   ifeq ($(call qstrip,$(CONFIG_EXTERNAL_KERNEL_TREE))$(call qstrip,$(CONFIG_KERNEL_GIT_CLONE_URI)),)
-      LINUX_SITE:=@KERNEL/linux/kernel/v3.x$(TESTING)
+      LINUX_SITE:=@KERNEL/linux/kernel/v$(word 1,$(subst ., ,$(KERNEL_BASE))).x$(TESTING)
   endif
 
   ifneq ($(TARGET_BUILD),1)
@@ -64,31 +62,55 @@ endif
 
 ifneq (,$(findstring uml,$(BOARD)))
   LINUX_KARCH=um
+else ifneq (,$(findstring $(ARCH) , aarch64 aarch64_be ))
+  LINUX_KARCH := arm64
+else ifneq (,$(findstring $(ARCH) , arceb ))
+  LINUX_KARCH := arc
+else ifneq (,$(findstring $(ARCH) , armeb ))
+  LINUX_KARCH := arm
+else ifneq (,$(findstring $(ARCH) , mipsel mips64 mips64el ))
+  LINUX_KARCH := mips
+else ifneq (,$(findstring $(ARCH) , sh2 sh3 sh4 ))
+  LINUX_KARCH := sh
+else ifneq (,$(findstring $(ARCH) , i386 x86_64 ))
+  LINUX_KARCH := x86
 else
-  ifeq (,$(LINUX_KARCH))
-    LINUX_KARCH=$(strip $(subst i386,x86,$(subst armeb,arm,$(subst mipsel,mips,$(subst mips64,mips,$(subst mips64el,mips,$(subst sh2,sh,$(subst sh3,sh,$(subst sh4,sh,$(ARCH))))))))))
-  endif
+  LINUX_KARCH := $(ARCH)
 endif
 
-
 define KernelPackage/Defaults
   FILES:=
   AUTOLOAD:=
+  PKGFLAGS+=nonshared
 endef
 
 define ModuleAutoLoad
        $(SH_FUNC) \
        export modules=; \
+       probe_module() { \
+               mods="$$$$$$$$1"; \
+               boot="$$$$$$$$2"; \
+               shift 2; \
+               for mod in $(sort $$$$$$$$mods); do \
+                       mkdir -p $(2)/etc/modules.d; \
+                       echo "$$$$$$$$mod" >> $(2)/etc/modules.d/$(1); \
+               done; \
+               if [ -e $(2)/etc/modules.d/$(1) ]; then \
+                       if [ "$$$$$$$$boot" = "1" ]; then \
+                               mkdir -p $(2)/etc/modules-boot.d; \
+                               ln -s ../modules.d/$(1) $(2)/etc/modules-boot.d/; \
+                       fi; \
+                       modules="$$$$$$$${modules:+$$$$$$$$modules }$$$$$$$$mods"; \
+               fi; \
+       }; \
        add_module() { \
                priority="$$$$$$$$1"; \
                mods="$$$$$$$$2"; \
                boot="$$$$$$$$3"; \
                shift 3; \
-               for mod in $$$$$$$$mods; do \
-                       if [ -e $(2)/$(MODULES_SUBDIR)/$$$$$$$$mod.ko ]; then \
-                               mkdir -p $(2)/etc/modules.d; \
-                               echo "$$$$$$$$mod" >> $(2)/etc/modules.d/$$$$$$$$priority-$(1); \
-                       fi; \
+               for mod in $(sort $$$$$$$$mods); do \
+                       mkdir -p $(2)/etc/modules.d; \
+                       echo "$$$$$$$$mod" >> $(2)/etc/modules.d/$$$$$$$$priority-$(1); \
                done; \
                if [ -e $(2)/etc/modules.d/$$$$$$$$priority-$(1) ]; then \
                        if [ "$$$$$$$$boot" = "1" ]; then \
@@ -102,11 +124,11 @@ define ModuleAutoLoad
        if [ -n "$$$$$$$$modules" ]; then \
                mkdir -p $(2)/etc/modules.d; \
                mkdir -p $(2)/CONTROL; \
-               echo "#!/bin/sh" > $(2)/CONTROL/postinst; \
-               echo "[ -z \"\$$$$$$$$IPKG_INSTROOT\" ] || exit 0" >> $(2)/CONTROL/postinst; \
-               echo ". /lib/functions.sh" >> $(2)/CONTROL/postinst; \
-               echo "insert_modules $$$$$$$$modules" >> $(2)/CONTROL/postinst; \
-               chmod 0755 $(2)/CONTROL/postinst; \
+               echo "#!/bin/sh" > $(2)/CONTROL/postinst-pkg; \
+               echo "[ -z \"\$$$$$$$$IPKG_INSTROOT\" ] || exit 0" >> $(2)/CONTROL/postinst-pkg; \
+               echo ". /lib/functions.sh" >> $(2)/CONTROL/postinst-pkg; \
+               echo "insert_modules $$$$$$$$modules" >> $(2)/CONTROL/postinst-pkg; \
+               chmod 0755 $(2)/CONTROL/postinst-pkg; \
        fi
 endef
 
@@ -134,10 +156,17 @@ define KernelPackage
     DESCRIPTION:=$(DESCRIPTION)
     EXTRA_DEPENDS:=kernel (=$(LINUX_VERSION)-$(LINUX_RELEASE)-$(LINUX_VERMAGIC))
     VERSION:=$(LINUX_VERSION)$(if $(PKG_VERSION),+$(PKG_VERSION))-$(if $(PKG_RELEASE),$(PKG_RELEASE),$(LINUX_RELEASE))
+    PKGFLAGS:=$(PKGFLAGS)
     $(call KernelPackage/$(1))
     $(call KernelPackage/$(1)/$(BOARD))
   endef
 
+  ifdef KernelPackage/$(1)/conffiles
+    define Package/kmod-$(1)/conffiles
+$(call KernelPackage/$(1)/conffiles)
+    endef
+  endif
+
   ifdef KernelPackage/$(1)/description
     define Package/kmod-$(1)/description
 $(call KernelPackage/$(1)/description)
@@ -155,19 +184,15 @@ $(call KernelPackage/$(1)/config)
   ifneq ($(if $(filter-out %=y %=n %=m,$(KCONFIG)),$(filter m y,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
     ifneq ($(strip $(FILES)),)
       define Package/kmod-$(1)/install
-                 @for mod in $$(FILES); do \
-                       if [ -e $$$$$$$$mod ]; then \
+                 @for mod in $$(call version_filter,$$(FILES)); do \
+                       if grep -q "$$$$$$$${mod##$(LINUX_DIR)/}" "$(LINUX_DIR)/modules.builtin"; then \
+                               echo "NOTICE: module '$$$$$$$$mod' is built-in."; \
+                       elif [ -e $$$$$$$$mod ]; then \
                                mkdir -p $$(1)/$(MODULES_SUBDIR) ; \
                                $(CP) -L $$$$$$$$mod $$(1)/$(MODULES_SUBDIR)/ ; \
-                       elif [ -e "$(LINUX_DIR)/modules.builtin" ]; then \
-                               if grep -q "$$$$$$$${mod##$(LINUX_DIR)/}" "$(LINUX_DIR)/modules.builtin"; then \
-                                       echo "NOTICE: module '$$$$$$$$mod' is built-in."; \
-                               else \
-                                       echo "ERROR: module '$$$$$$$$mod' is missing." >&2; \
-                                       exit 1; \
-                               fi; \
                        else \
-                               echo "WARNING: module '$$$$$$$$mod' missing and modules.builtin not available, assuming built-in." >&2; \
+                               echo "ERROR: module '$$$$$$$$mod' is missing." >&2; \
+                               exit 1; \
                        fi; \
                  done;
                  $(call ModuleAutoLoad,$(1),$$(1),$(AUTOLOAD))
@@ -176,9 +201,13 @@ $(call KernelPackage/$(1)/config)
     endif
   $(if $(CONFIG_PACKAGE_kmod-$(1)),
     else
-      compile: kmod-$(1)-unavailable
-      kmod-$(1)-unavailable:
-               @echo "WARNING: kmod-$(1) is not available in the kernel config" >&2
+      compile: $(1)-disabled
+      $(1)-disabled:
+               @echo "WARNING: kmod-$(1) is not available in the kernel config - generating empty package" >&2
+
+      define Package/kmod-$(1)/install
+               true
+      endef
   )
   endif
   $$(eval $$(call BuildPackage,kmod-$(1)))
@@ -186,8 +215,14 @@ $(call KernelPackage/$(1)/config)
   $$(IPKG_kmod-$(1)): $$(wildcard $$(FILES))
 endef
 
+version_filter=$(if $(findstring @,$(1)),$(shell $(SCRIPT_DIR)/package-metadata.pl version_filter $(KERNEL_PATCHVER) $(1)),$(1))
+
 define AutoLoad
-  add_module "$(1)" "$(2)" "$(3)";
+  add_module "$(1)" "$(call version_filter,$(2))" "$(3)";
+endef
+
+define AutoProbe
+  probe_module "$(call version_filter,$(1))" "$(2)";
 endef
 
 version_field=$(if $(word $(1),$(2)),$(word $(1),$(2)),0)