update to 2.6.28.5
[openwrt/openwrt.git] / include / kernel.mk
index b82668ea48d1755d6fada59b7b07788e8ad75083..28567776adec2182daef034aa927c221f7d1ba52 100644 (file)
@@ -23,14 +23,15 @@ else
   endif
 
   ifneq (,$(findstring uml,$(BOARD)))
-    KERNEL_CC:=$(HOSTCC)
-    KERNEL_CROSS:=
+    KERNEL_CC?=$(HOSTCC)
+    KERNEL_CROSS?=
   else
-    KERNEL_CC:=$(TARGET_CC)
-    KERNEL_CROSS:=$(TARGET_CROSS)
+    KERNEL_CC?=$(TARGET_CC)
+    KERNEL_CROSS?=$(TARGET_CROSS)
   endif
 
   PATCH_DIR ?= ./patches$(shell [ -d "./patches-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
+  FILES_DIR ?= $(foreach dir,$(wildcard ./files ./files-$(KERNEL_PATCHVER)),"$(dir)")
   KERNEL_BUILD_DIR ?= $(BUILD_DIR_BASE)/linux-$(BOARD)$(if $(SUBTARGET),_$(SUBTARGET))$(if $(BUILD_SUFFIX),_$(BUILD_SUFFIX))
   LINUX_DIR ?= $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)
 
@@ -43,19 +44,22 @@ else
   TESTING:=$(if $(findstring -rc,$(LINUX_VERSION)),/testing,)
   LINUX_SITE:=@KERNEL/linux/kernel/v$(KERNEL)$(TESTING) \
 
-  PKG_BUILD_DIR ?= $(KERNEL_BUILD_DIR)/$(PKG_NAME)$(if $(PKG_VERSION),-$(PKG_VERSION))
+  ifneq ($(TARGET_BUILD),1)
+    PKG_BUILD_DIR ?= $(KERNEL_BUILD_DIR)/$(PKG_NAME)$(if $(PKG_VERSION),-$(PKG_VERSION))
+  endif
 endif
 
 ifneq (,$(findstring uml,$(BOARD)))
   LINUX_KARCH:=um
 else
-  LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
-       -e 's/mipsel/mips/' \
-       -e 's/mipseb/mips/' \
-       -e 's/powerpc/ppc/' \
-       -e 's/sh[234]/sh/' \
-       -e 's/armeb/arm/' \
-  )
+  ifeq (,$(LINUX_KARCH))
+    LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/x86/' \
+         -e 's/mipsel/mips/' \
+         -e 's/mipseb/mips/' \
+         -e 's/sh[234]/sh/' \
+         -e 's/armeb/arm/' \
+    )
+  endif
 endif
 
 
@@ -85,7 +89,10 @@ define ModuleAutoLoad
                chmod 0755 $(2)/CONTROL/postinst; \
        fi
 endef
+
+ifeq ($(DUMP)$(TARGET_BUILD),)
+  -include $(LINUX_DIR)/.config
+endif
 
 define KernelPackage
   NAME:=$(1)
@@ -113,8 +120,15 @@ $(call KernelPackage/$(1)/description)
     endef
   endif
 
-  # check that all CONFIG_* symbols in $(KCONFIG) are set to 'm'
-  ifeq ($(filter-out m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$(if $($(c)),$($(c)),n))),)
+  ifdef KernelPackage/$(1)/config
+    define Package/kmod-$(1)/config
+$(call KernelPackage/$(1)/config)
+    endef
+  endif
+
+  $(STAMP_BUILT): $(LINUX_DIR)/.config
+
+  ifneq ($(if $(filter-out %=y %=n %=m,$(KCONFIG)),$(filter m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
     ifneq ($(strip $(FILES)),)
       define Package/kmod-$(1)/install
                  mkdir -p $$(1)/lib/modules/$(LINUX_VERSION)
@@ -123,6 +137,12 @@ $(call KernelPackage/$(1)/description)
                  $(call KernelPackage/$(1)/install,$$(1))
       endef
     endif
+  $(if $(CONFIG_PACKAGE_kmod-$(1)),
+    else
+      compile: kmod-$(1)-unavailable
+      kmod-$(1)-unavailable:
+               @echo "WARNING: kmod-$(1) is not available in the kernel config"
+  )
   endif
   $$(eval $$(call BuildPackage,kmod-$(1)))
 
@@ -133,3 +153,7 @@ define AutoLoad
   add_module $(1) "$(2)";
 endef
 
+define CompareKernelPatchVer
+  $(shell [ $$(echo $(1) | tr . 0) -$(2) $$(echo $(3) | tr . 0) ] && echo 1 || echo 0)
+endef
+