don't specify "CC=<nothing>" on kernel build command line
[openwrt/openwrt.git] / include / kernel.mk
index f9baeef0ac3daa5505344310b9656c49c960931a..4bdd24a5924df06bcb837f5a59e22916d296f835 100644 (file)
@@ -23,11 +23,11 @@ else
   endif
 
   ifneq (,$(findstring uml,$(BOARD)))
-    KERNEL_CC:=$(HOSTCC)
-    KERNEL_CROSS:=
+    KERNEL_CC?=$(HOSTCC)
+    KERNEL_CROSS?=
   else
-    KERNEL_CC:=$(TARGET_CC)
-    KERNEL_CROSS:=$(TARGET_CROSS)
+    KERNEL_CC?=$(TARGET_CC)
+    KERNEL_CROSS?=$(TARGET_CROSS)
   endif
 
   PATCH_DIR ?= ./patches$(shell [ -d "./patches-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )