refresh atheros config, add missing symbols to generic 2.6.26 config
[openwrt/openwrt.git] / include / kernel.mk
index 460269949b1422b2fcf1165354a9fa3fbc275ad2..7d986e4597ebbe0fd09c443fa58abebd0d50e5f4 100644 (file)
@@ -31,6 +31,7 @@ else
   endif
 
   PATCH_DIR ?= ./patches$(shell [ -d "./patches-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
+  FILES_DIR ?= ./files$(shell [ -d "./files-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
   KERNEL_BUILD_DIR ?= $(BUILD_DIR_BASE)/linux-$(BOARD)$(if $(SUBTARGET),_$(SUBTARGET))$(if $(BUILD_SUFFIX),_$(BUILD_SUFFIX))
   LINUX_DIR ?= $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)
 
@@ -89,7 +90,7 @@ define ModuleAutoLoad
        fi
 endef
 
-ifeq ($(DUMP),)
+ifeq ($(DUMP)$(TARGET_BUILD),)
   -include $(LINUX_DIR)/.config
 endif
 
@@ -119,6 +120,12 @@ $(call KernelPackage/$(1)/description)
     endef
   endif
 
+  ifdef KernelPackage/$(1)/config
+    define Package/kmod-$(1)/config
+$(call KernelPackage/$(1)/config)
+    endef
+  endif
+
   ifneq ($(if $(KCONFIG),$(filter m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
     ifneq ($(strip $(FILES)),)
       define Package/kmod-$(1)/install
@@ -144,3 +151,7 @@ define AutoLoad
   add_module $(1) "$(2)";
 endef
 
+define CompareKernelPatchVer
+  $(shell [ $$(echo $(1) | tr . 0) -$(2) $$(echo $(3) | tr . 0) ] && echo 1 || echo 0)
+endef
+