linux: add support of Synopsys ARC770-based boards
[openwrt/openwrt.git] / include / kernel.mk
index 6a613fe1fda7f56d8669adaf4d222cbfa1097665..878a366fc4dc9ef2199c66a1c048258e28469659 100644 (file)
@@ -64,6 +64,8 @@ ifneq (,$(findstring uml,$(BOARD)))
   LINUX_KARCH=um
 else ifneq (,$(findstring $(ARCH) , aarch64 aarch64_be ))
   LINUX_KARCH := arm64
+else ifneq (,$(findstring $(ARCH) , arceb ))
+  LINUX_KARCH := arc
 else ifneq (,$(findstring $(ARCH) , armeb ))
   LINUX_KARCH := arm
 else ifneq (,$(findstring $(ARCH) , mipsel mips64 mips64el ))