require all CONFIG_* symbols listed in its KCONFIG to be set to m in order to actuall...
[openwrt/openwrt.git] / include / kernel.mk
index 519ea42d23bfe3cc912db267ddbe9b61a009a811..a0f256b998c32345e9cb5bdf774f3d6253628b9d 100644 (file)
@@ -104,7 +104,8 @@ $(call KernelPackage/$(1)/description)
     endef
   endif
 
-  ifneq ($(if $(KCONFIG),$(filter m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
+  # check that all CONFIG_* symbols in $(KCONFIG) are set to 'm'
+  ifeq ($(filter-out m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$(if $($(c)),$($(c)),n))),)
     ifneq ($(strip $(FILES)),)
       define Package/kmod-$(1)/install
                  mkdir -p $$(1)/lib/modules/$(LINUX_VERSION)