add a macro to compare kernel patch versions and use it for crypto and watchdog chang...
[openwrt/openwrt.git] / include / kernel.mk
index 52355dcdd313d79a148ca92afbac7cab7bb7ba93..b80c3b63ff8ffc6b6c7aea3d44055d43915ddde4 100644 (file)
@@ -145,3 +145,7 @@ define AutoLoad
   add_module $(1) "$(2)";
 endef
 
+define CompareKernelPatchVer
+  $(shell [ $$(echo $(1) | tr . 0) -$(2) $$(echo $(3) | tr . 0) ] && echo 1 || echo 0)
+endef
+