build system: introduce a new feature called build variants. it allows building a...
[openwrt/openwrt.git] / include / package-defaults.mk
index 700bc5b99044398ca67d27be02f9c9773184271d..017a86d1e8d0d4309d10602093be10aa90b16d1e 100644 (file)
@@ -23,7 +23,11 @@ define Package/Default
   else
     VERSION:=$(PKG_RELEASE)
   endif
-  PKGARCH:=$(ARCH)
+  ifneq ($(CONFIG_TARGET_adm5120),y)
+    PKGARCH:=$(BOARD)
+  else
+    PKGARCH:=$(BOARD)_$(ARCH)
+  endif
   PRIORITY:=optional
   DEFAULT:=
   MENU:=
@@ -33,6 +37,7 @@ define Package/Default
   KCONFIG:=
   BUILDONLY:=
   URL:=
+  VARIANT:=
 endef
 
 Build/Patch:=$(Build/Patch/Default)
@@ -60,7 +65,9 @@ CONFIGURE_ARGS = \
                --localstatedir=/var \
                --mandir=$(CONFIGURE_PREFIX)/man \
                --infodir=$(CONFIGURE_PREFIX)/info \
-               $(DISABLE_NLS)
+               $(DISABLE_NLS) \
+               $(DISABLE_LARGEFILE) \
+               $(DISABLE_IPV6)
 
 CONFIGURE_VARS = \
                $(TARGET_CONFIGURE_OPTS) \
@@ -117,3 +124,11 @@ define Build/Install/Default
                $(MAKE_INSTALL_FLAGS) \
                $(1) install;
 endef
+
+define Build/Dist/Default
+       $(call Build/Compile/Default, DESTDIR="$(PKG_BUILD_DIR)/tmp" CC="$(TARGET_CC)" dist)
+endef
+
+define Build/DistCheck/Default
+       $(call Build/Compile/Default, DESTDIR="$(PKG_BUILD_DIR)/tmp" CC="$(TARGET_CC)" distcheck)
+endef