tahvo doesn't need ohci
[openwrt/openwrt.git] / include / package-dumpinfo.mk
index db8d9c11ca53ace356ee09adfcc5527f6b701eb6..34196e408611ac0b9f3ba046057b6468554c9c18 100644 (file)
@@ -22,7 +22,7 @@ define Config
   preconfig_$$(1) += $(1)
 endef
 
-define Dumpinfo
+define Dumpinfo/Package
 $(info Package: $(1)
 $(if $(MENU),Menu: $(MENU)
 )$(if $(SUBMENU),Submenu: $(SUBMENU)
@@ -32,7 +32,8 @@ $(if $(MENU),Menu: $(MENU)
 )Version: $(VERSION)
 Depends: $(DEPENDS)
 Provides: $(PROVIDES)
-$(if $(PKG_BUILD_DEPENDS),Build-Depends: $(PKG_BUILD_DEPENDS)
+$(if $(VARIANT),Build-Variant: $(VARIANT)
+)$(if $(PKG_BUILD_DEPENDS),Build-Depends: $(PKG_BUILD_DEPENDS)
 )$(if $(HOST_BUILD_DEPENDS),Build-Depends/host: $(HOST_BUILD_DEPENDS)
 )$(if $(BUILD_TYPES),Build-Types: $(BUILD_TYPES)
 )Section: $(SECTION)
@@ -45,11 +46,38 @@ $(if $(KCONFIG),Kernel-Config: $(KCONFIG)
 )$(if $(BUILDONLY),Build-Only: $(BUILDONLY)
 )Description: $(if $(Package/$(1)/description),$(Package/$(1)/description),$(TITLE))
 $(if $(URL),$(URL)
-)@@
+)$(MAINTAINER)
+@@
 $(if $(Package/$(1)/config),Config:
 $(Package/$(1)/config)
 @@
 )$(foreach pc,$(preconfig_$(1)),
 $(Preconfig/$(pc))))
-  endef
+endef
+
+define Feature/Default
+  TARGET_NAME:=
+  TARGET_TITLE:=
+  PRIORITY:=
+  NAME:=
+endef
+
+define Feature
+  $(eval $(Feature/Default))
+  $(eval $(Feature/$(1)))
+  $(if $(DUMP),$(call Dumpinfo/Feature,$(1)))
+endef
+
+define Dumpinfo/Feature
+$(info Feature: $(TARGET_NAME)_$(1)
+Target-Name: $(TARGET_NAME)
+Target-Title: $(TARGET_TITLE)
+Feature-Name: $(NAME)
+$(if $(PRIORITY),Feature-Priority: $(PRIORITY)
+)Feature-Description:
+$(Feature/$(1)/description)
+@@
+)
+endef
+
 endif