Add an 'Image Configuration' menu to menuconfig Packages can export a list of config...
[openwrt/openwrt.git] / include / package-ipkg.mk
index 0d6ab8af91da5458852710e3a00311c5d4472fdf..0f98dcfe14ece399fc043c026e9f78a308f0ca43 100644 (file)
@@ -54,12 +54,14 @@ define BuildIPKG
                done; \
                echo "Depends: $$$$DEPENDS" >> $$(IDIR_$(1))/CONTROL/control; \
        )
-       echo "Source: $(SOURCE)" >> $$(IDIR_$(1))/CONTROL/control
-       echo "Section: $(SECTION)" >> $$(IDIR_$(1))/CONTROL/control
-       echo "Priority: $(PRIORITY)" >> $$(IDIR_$(1))/CONTROL/control
-       echo "Maintainer: $(MAINTAINER)" >> $$(IDIR_$(1))/CONTROL/control
-       echo "Architecture: $(PKGARCH)" >> $$(IDIR_$(1))/CONTROL/control
-       echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n,g' | sed -e 's,^[[:space:]]*$$$$, .,g' >> $$(IDIR_$(1))/CONTROL/control
+       ( \
+               echo "Source: $(SOURCE)"; \
+               echo "Section: $(SECTION)"; \
+               echo "Priority: $(PRIORITY)"; \
+               echo "Maintainer: $(MAINTAINER)"; \
+               echo "Architecture: $(PKGARCH)"; \
+               echo -n "Description: "; getvar $(call shvar,Package/$(1)/description) | sed -e 's,^[[:space:]]*, ,g'; \
+       ) >> $$(IDIR_$(1))/CONTROL/control
        chmod 644 $$(IDIR_$(1))/CONTROL/control
        (cd $$(IDIR_$(1))/CONTROL; \
                $($(1)_COMMANDS) \