move IPKG_STATE_DIR from ./rules.mk to ./include/package-ipkg.mk and change its value...
[openwrt/openwrt.git] / include / package-ipkg.mk
index de9798413d3a33a465c7e77c749628058e487931..8b4c042a076775f0df48d1426a4afe9e167d62f8 100644 (file)
@@ -17,6 +17,8 @@ IPKG:= \
 IPKG_BUILD:= \
   ipkg-build -c -o 0 -g 0
 
+IPKG_STATE_DIR:=$(TARGET_DIR)/usr/lib/opkg
+
 define BuildIPKGVariable
   $(call shexport,Package/$(1)/$(2))
   $(1)_COMMANDS += var2file "$(call shvar,Package/$(1)/$(2))" $(2);
@@ -25,7 +27,8 @@ endef
 dep_split=$(subst :,$(space),$(1))
 dep_confvar=CONFIG_$(word 1,$(call dep_split,$(1)))
 dep_val=$(word 2,$(call dep_split,$(1)))
-filter_deps=$(foreach dep,$(1),$(if $(findstring :,$(dep)),$(if $($(call dep_confvar,$(dep))),$(call dep_val,$(dep))),$(dep)))
+strip_deps=$(strip $(subst +,,$(filter-out @%,$(1))))
+filter_deps=$(foreach dep,$(call strip_deps,$(1)),$(if $(findstring :,$(dep)),$(if $($(call dep_confvar,$(dep))),$(call dep_val,$(dep))),$(dep)))
 
 ifeq ($(DUMP),)
   define BuildTarget/ipkg
@@ -47,7 +50,7 @@ ifeq ($(DUMP),)
       endif
     endif
 
-    IDEPEND_$(1):=$$(call filter_deps,$$(strip $$(DEPENDS)))
+    IDEPEND_$(1):=$$(call filter_deps,$$(DEPENDS))
   
     $(eval $(call BuildIPKGVariable,$(1),conffiles))
     $(eval $(call BuildIPKGVariable,$(1),preinst))
@@ -71,6 +74,7 @@ ifeq ($(DUMP),)
                echo "Priority: $(PRIORITY)"; \
                echo "Maintainer: $(MAINTAINER)"; \
                echo "Architecture: $(PKGARCH)"; \
+               echo "Installed-Size: 1"; \
                echo -n "Description: "; getvar $(call shvar,Package/$(1)/description) | sed -e 's,^[[:space:]]*, ,g'; \
        ) >> $$(IDIR_$(1))/CONTROL/control
        chmod 644 $$(IDIR_$(1))/CONTROL/control
@@ -83,6 +87,8 @@ ifeq ($(DUMP),)
        mkdir -p $(PACKAGE_DIR)
        -find $$(IDIR_$(1)) -name 'CVS' -o -name '.svn' -o -name '.#*' | $(XARGS) rm -rf
        $(RSTRIP) $$(IDIR_$(1))
+       SIZE=`cd $$(IDIR_$(1)); du -bs --exclude=./CONTROL . 2>/dev/null | cut -f1`; \
+       $(SED) "s|^\(Installed-Size:\).*|\1 $$$$SIZE|g" $$(IDIR_$(1))/CONTROL/control
        $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
        @[ -f $$(IPKG_$(1)) ] || false