fix conditional depends in ipkg control files
[openwrt/openwrt.git] / include / package-ipkg.mk
index 86c802289c34d38556a6360243657cac18ca5043..c5d4916c2cd59f0ed2a3a0e8761a72d7d28abee2 100644 (file)
@@ -5,13 +5,31 @@
 # See /LICENSE for more information.
 #
 
+# where to build (and put) .ipk packages
+IPKG:= \
+  IPKG_TMP=$(TMP_DIR)/ipkg \
+  IPKG_INSTROOT=$(TARGET_DIR) \
+  IPKG_CONF_DIR=$(STAGING_DIR)/etc \
+  IPKG_OFFLINE_ROOT=$(TARGET_DIR) \
+  $(SCRIPT_DIR)/ipkg -force-defaults -force-depends
+
+# invoke ipkg-build with some default options
+IPKG_BUILD:= \
+  ipkg-build -c -o 0 -g 0
+
 define BuildIPKGVariable
   $(call shexport,Package/$(1)/$(2))
   $(1)_COMMANDS += var2file "$(call shvar,Package/$(1)/$(2))" $(2);
 endef
 
+dep_split=$(subst :,$(space),$(1))
+dep_confvar=CONFIG_$(word 1,$(call dep_split,$(1)))
+dep_val=$(word 2,$(call dep_split,$(1)))
+strip_deps=$(strip $(subst +,,$(filter-out @%,$(1))))
+filter_deps=$(foreach dep,$(call strip_deps,$(1)),$(if $(findstring :,$(dep)),$(if $($(call dep_confvar,$(dep))),$(call dep_val,$(dep))),$(dep)))
+
 ifeq ($(DUMP),)
-  define BuildIPKG
+  define BuildTarget/ipkg
     IPKG_$(1):=$(PACKAGE_DIR)/$(1)_$(VERSION)_$(PKGARCH).ipk
     IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(1)
     INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
@@ -23,14 +41,6 @@ ifeq ($(DUMP),)
         ifeq ($(CONFIG_PACKAGE_$(1)),y)
           install: $$(INFO_$(1))
         endif
-
-        ifneq ($(MAKECMDGOALS),prereq)
-          ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install '$$(IPKG_$(1))' '$(PKG_BUILD_DIR)'),$$(IPKG_$(1)))
-            $(PKG_BUILD_DIR)/.built: package-rebuild
-            $$(info Rebuilding $(subst $(TOPDIR)/,,$$(IPKG_$(1))))
-          endif
-        endif
-
       else
         compile: $(1)-disabled
         $(1)-disabled:
@@ -38,7 +48,7 @@ ifeq ($(DUMP),)
       endif
     endif
 
-    IDEPEND_$(1):=$$(strip $$(DEPENDS))
+    IDEPEND_$(1):=$$(call filter_deps,$$(DEPENDS))
   
     $(eval $(call BuildIPKGVariable,$(1),conffiles))
     $(eval $(call BuildIPKGVariable,$(1),preinst))
@@ -56,6 +66,7 @@ ifeq ($(DUMP),)
                        DEPENDS=$$$${DEPENDS:+$$$$DEPENDS, }$$$${depend##+}; \
                done; \
                echo "Depends: $$$$DEPENDS"; \
+               echo "Provides: $(PROVIDES)"; \
                echo "Source: $(SOURCE)"; \
                echo "Section: $(SECTION)"; \
                echo "Priority: $(PRIORITY)"; \
@@ -68,12 +79,10 @@ ifeq ($(DUMP),)
                $($(1)_COMMANDS) \
        )
 
-    $$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
+    $$(IPKG_$(1)): $(STAGING_DIR)/etc/ipkg.conf $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
        $(call Package/$(1)/install,$$(IDIR_$(1)))
        mkdir -p $(PACKAGE_DIR)
-       -find $$(IDIR_$(1)) -name CVS   | xargs -r rm -rf
-       -find $$(IDIR_$(1)) -name .svn  | xargs -r rm -rf
-       -find $$(IDIR_$(1)) -name '.#*' | xargs -r rm -f
+       -find $$(IDIR_$(1)) -name 'CVS' -o -name '.svn' -o -name '.#*' | $(XARGS) rm -rf
        $(RSTRIP) $$(IDIR_$(1))
        $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
        @[ -f $$(IPKG_$(1)) ] || false 
@@ -86,11 +95,14 @@ ifeq ($(DUMP),)
 
     clean: $(1)-clean
 
-    $(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH): $(PKG_BUILD_DIR)/.prepared
+    $(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH): $(STAMP_PREPARED)
        -@rm -f $(PKG_BUILD_DIR)/.version-$(1)_* 2>/dev/null
        @touch $$@
+  endef
 
-    $$(eval $$(call Build/DefaultTargets,$(1)))
+  $(STAGING_DIR)/etc/ipkg.conf:
+       mkdir -p $(STAGING_DIR)/etc
+       echo "dest root /" > $(STAGING_DIR)/etc/ipkg.conf
+       echo "option offline_root $(TARGET_DIR)" >> $(STAGING_DIR)/etc/ipkg.conf
 
-  endef
 endif