build: add support for specifying extra package dependencies for prepared, configured...
[openwrt/openwrt.git] / include / package.mk
index ff9a5df9e6698512479d4f5add1410b34588afb0..092811c2c2016a94dfb753ef86318849cc8183ff 100644 (file)
@@ -167,7 +167,7 @@ define Build/DefaultTargets
        )
 
   $(STAMP_PREPARED) : export PATH=$$(TARGET_PATH_PKG)
-  $(STAMP_PREPARED):
+  $(STAMP_PREPARED): $(STAMP_PREPARED_DEPENDS)
        @-rm -rf $(PKG_BUILD_DIR)
        @mkdir -p $(PKG_BUILD_DIR)
        $(foreach hook,$(Hooks/Prepare/Pre),$(call $(hook))$(sep))
@@ -176,7 +176,7 @@ define Build/DefaultTargets
        touch $$@
 
   $(call Build/Exports,$(STAMP_CONFIGURED))
-  $(STAMP_CONFIGURED): $(STAMP_PREPARED)
+  $(STAMP_CONFIGURED): $(STAMP_PREPARED) $(STAMP_CONFIGURED_DEPENDS)
        $(CleanStaging)
        $(foreach hook,$(Hooks/Configure/Pre),$(call $(hook))$(sep))
        $(Build/Configure)
@@ -185,7 +185,7 @@ define Build/DefaultTargets
        touch $$@
 
   $(call Build/Exports,$(STAMP_BUILT))
-  $(STAMP_BUILT): $(STAMP_CONFIGURED)
+  $(STAMP_BUILT): $(STAMP_CONFIGURED) $(STAMP_BUILT_DEPENDS)
        $(foreach hook,$(Hooks/Compile/Pre),$(call $(hook))$(sep))
        $(Build/Compile)
        $(foreach hook,$(Hooks/Compile/Post),$(call $(hook))$(sep))