add a second parameter to InstallDev/UninstallDev for specifying the path to STAGING_...
[openwrt/openwrt.git] / include / package.mk
index 90750fe26bdca4af5cd6fa5d6c198936421b5d38..9ab3a2cd5c8fe7a8bc955d74d9138e7d1402c6ee 100644 (file)
@@ -70,7 +70,7 @@ define Build/DefaultTargets
        touch $$@
 
   $(STAMP_INSTALLED): $(STAMP_BUILT)
        touch $$@
 
   $(STAMP_INSTALLED): $(STAMP_BUILT)
-       $(call Build/InstallDev,$(STAGING_DIR))
+       $(call Build/InstallDev,$(STAGING_DIR),$(STAGING_DIR_HOST))
        touch $$@
 
   ifdef Build/InstallDev
        touch $$@
 
   ifdef Build/InstallDev
@@ -160,7 +160,7 @@ configure:
 compile:
 install:
 clean: FORCE
 compile:
 install:
 clean: FORCE
-       $(call Build/UninstallDev,$(STAGING_DIR))
+       $(call Build/UninstallDev,$(STAGING_DIR),$(STAGING_DIR_HOST))
        $(Build/Clean)
        @rm -f $(STAGING_DIR)/stamp/.$(PKG_NAME)-installed
        @rm -rf $(PKG_BUILD_DIR)
        $(Build/Clean)
        @rm -f $(STAGING_DIR)/stamp/.$(PKG_NAME)-installed
        @rm -rf $(PKG_BUILD_DIR)