port generic and ixp4xx kernel patches to 2.6.27 (compiles except for iptables, but...
[openwrt/openwrt.git] / include / package.mk
index e0f8c719f4cfe14af55fe587a4152c6e7472421f..d67a386225eacedbe82401850f6f8266358d645a 100644 (file)
@@ -1,9 +1,10 @@
-# 
-# Copyright (C) 2006-2007 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+# $Id$
 
 all: $(if $(DUMP),dumpinfo,compile)
 
@@ -89,7 +90,13 @@ define Build/DefaultTargets
        $(SUBMAKE) -j1 clean-staging
        rm -rf $(TMP_DIR)/stage-$(PKG_NAME)
        mkdir -p $(TMP_DIR)/stage-$(PKG_NAME)/host $(STAGING_DIR)/packages $(STAGING_DIR_HOST)/packages
+       $(foreach hook,$(Hooks/InstallDev/Pre),\
+               $(call $(hook),$(TMP_DIR)/stage-$(PKG_NAME),$(TMP_DIR)/stage-$(PKG_NAME)/host)$(sep)\
+       )
        $(call Build/InstallDev,$(TMP_DIR)/stage-$(PKG_NAME),$(TMP_DIR)/stage-$(PKG_NAME)/host)
+       $(foreach hook,$(Hooks/InstallDev/Post),\
+               $(call $(hook),$(TMP_DIR)/stage-$(PKG_NAME),$(TMP_DIR)/stage-$(PKG_NAME)/host)$(sep)\
+       )
        if [ -d $(TMP_DIR)/stage-$(PKG_NAME) ]; then \
                (cd $(TMP_DIR)/stage-$(PKG_NAME); find ./ > $(STAGING_DIR)/packages/$(PKG_NAME).list); \
                $(CP) $(TMP_DIR)/stage-$(PKG_NAME)/* $(STAGING_DIR)/; \
@@ -150,17 +157,10 @@ define pkg_install_bin
        $(foreach install_apps,$(1),$(INSTALL_DIR) $(3)/`dirname $(install_apps)`; $(INSTALL_BIN) $(2)/$(install_apps) $(3)/`dirname $(install_apps)`;)
 endef
 
-define Build/Prepare
-  $(call Build/Prepare/Default,)
-endef
-
-define Build/Configure
-  $(call Build/Configure/Default,)
-endef
-
-define Build/Compile
-  $(call Build/Compile/Default,)
-endef
+Build/Prepare=$(call Build/Prepare/Default,)
+Build/Configure=$(call Build/Configure/Default,)
+Build/Compile=$(call Build/Compile/Default,)
+Build/Install=$(if $(PKG_INSTALL),$(call Build/Install/Default,))
 
 $(PACKAGE_DIR):
        mkdir -p $@