image.mk: force rebuild of kernel dependent parts - fixes auto-rebuild on DTS changes
[openwrt/openwrt.git] / include / prereq-build.mk
index 7945f053251b3ce5f5c76e1c3faadd245ff0e711..211201af3da1e0aaf85a2b3701f78c3bd0d6f499 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -31,7 +31,8 @@ $(eval $(call SetupHostCommand,gcc, \
        gcc49 --version | grep gcc, \
        gcc48 --version | grep gcc, \
        gcc47 --version | grep gcc, \
-       gcc46 --version | grep gcc))
+       gcc46 --version | grep gcc, \
+       gcc --version | grep Apple.LLVM ))
 
 $(eval $(call TestHostCommand,working-gcc, \
        Please reinstall the GNU C Compiler - it appears to be broken, \
@@ -45,7 +46,8 @@ $(eval $(call SetupHostCommand,g++, \
        g++49 --version | grep g++, \
        g++48 --version | grep g++, \
        g++47 --version | grep g++, \
-       g++46 --version | grep g++))
+       g++46 --version | grep g++, \
+       g++ --version | grep Apple.LLVM ))
 
 $(eval $(call TestHostCommand,working-g++, \
        Please reinstall the GNU C++ Compiler - it appears to be broken, \
@@ -132,7 +134,7 @@ $(eval $(call SetupHostCommand,wget,Please install GNU 'wget', \
        wget --version | grep GNU))
 
 $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
-       perl --version | grep "perl 5"))
+       perl --version | grep "perl.*v5"))
 
 $(eval $(call SetupHostCommand,python,Please install Python 2.x, \
        python2.7 -V 2>&1 | grep Python, \
@@ -146,7 +148,7 @@ $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.6.5, \
        git clone 2>&1 | grep -- --recursive))
 
 $(eval $(call SetupHostCommand,file,Please install the 'file' package, \
-       file --version | grep file))
+       file --version 2>&1 | grep file))
 
 $(eval $(call SetupHostCommand,openssl,Please install the 'openssl' utility, \
        openssl version | grep OpenSSL))