build: remove GNU time dependency
[openwrt/openwrt.git] / include / prereq-build.mk
index 211201af3da1e0aaf85a2b3701f78c3bd0d6f499..a416a2d2320990ef1888b621691246cf4eea4af1 100644 (file)
@@ -7,8 +7,6 @@
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/prereq.mk
-include $(INCLUDE_DIR)/host.mk
-include $(INCLUDE_DIR)/host-build.mk
 
 SHELL:=sh
 PKG_NAME:=Build dependency
@@ -24,33 +22,45 @@ $(eval $(call TestHostCommand,case-sensitive-fs, \
        rm -f $(TMP_DIR)/test.*; touch $(TMP_DIR)/test.fs; \
                test ! -f $(TMP_DIR)/test.FS))
 
+$(eval $(call TestHostCommand,proper-umask, \
+       Please build with umask 022 - other values produce broken packages, \
+       umask | grep -xE 00[012][012]))
+
 $(eval $(call SetupHostCommand,gcc, \
-       Please install the GNU C Compiler (gcc), \
-       $(CC) --version | grep gcc, \
-       gcc --version | grep gcc, \
-       gcc49 --version | grep gcc, \
+       Please install the GNU C Compiler (gcc) 4.8 or later, \
+       $(CC) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
+       gcc -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
        gcc48 --version | grep gcc, \
-       gcc47 --version | grep gcc, \
-       gcc46 --version | grep gcc, \
+       gcc49 --version | grep gcc, \
+       gcc5 --version | grep gcc, \
+       gcc6 --version | grep gcc, \
+       gcc7 --version | grep gcc, \
+       gcc8 --version | grep gcc, \
+       gcc9 --version | grep gcc, \
        gcc --version | grep Apple.LLVM ))
 
 $(eval $(call TestHostCommand,working-gcc, \
-       Please reinstall the GNU C Compiler - it appears to be broken, \
+       \nPlease reinstall the GNU C Compiler (4.8 or later) - \
+       it appears to be broken, \
        echo 'int main(int argc, char **argv) { return 0; }' | \
                gcc -x c -o $(TMP_DIR)/a.out -))
 
 $(eval $(call SetupHostCommand,g++, \
-       Please install the GNU C++ Compiler (g++), \
-       $(CXX) --version | grep g++, \
-       g++ --version | grep g++, \
-       g++49 --version | grep g++, \
+       Please install the GNU C++ Compiler (g++) 4.8 or later, \
+       $(CXX) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
+       g++ -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
        g++48 --version | grep g++, \
-       g++47 --version | grep g++, \
-       g++46 --version | grep g++, \
+       g++49 --version | grep g++, \
+       g++5 --version | grep g++, \
+       g++6 --version | grep g++, \
+       g++7 --version | grep g++, \
+       g++8 --version | grep g++, \
+       g++9 --version | grep g++, \
        g++ --version | grep Apple.LLVM ))
 
 $(eval $(call TestHostCommand,working-g++, \
-       Please reinstall the GNU C++ Compiler - it appears to be broken, \
+       \nPlease reinstall the GNU C++ Compiler (4.8 or later) - \
+       it appears to be broken, \
        echo 'int main(int argc, char **argv) { return 0; }' | \
                g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \
                $(TMP_DIR)/a.out))
@@ -60,15 +70,15 @@ $(eval $(call TestHostCommand,ncurses, \
        echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
                gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses))
 
-$(eval $(call TestHostCommand,zlib, \
-       Please install zlib. (Missing libz.so or zlib.h), \
-       echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
-               gcc -include zlib.h -x c -o $(TMP_DIR)/a.out - -lz))
+ifeq ($(HOST_OS),Linux)
+  zlib_link_flags := -Wl,-Bstatic -lz -Wl,-Bdynamic
+else
+  zlib_link_flags := -lz
+endif
 
-$(eval $(call TestHostCommand,libssl, \
-       Please install the openssl library (with development headers), \
-       echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
-               gcc -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl))
+$(eval $(call TestHostCommand,perl-thread-queue, \
+       Please install the Perl Thread::Queue module, \
+       perl -MThread::Queue -e 1))
 
 
 $(eval $(call SetupHostCommand,tar,Please install GNU 'tar', \
@@ -92,8 +102,8 @@ $(eval $(call SetupHostCommand,diff,Please install diffutils, \
        diff --version 2>&1 | grep diff))
 
 $(eval $(call SetupHostCommand,cp,Please install GNU fileutils, \
-       gcp --help, \
-       cp --help))
+       gcp --help 2>&1 | grep 'Copy SOURCE', \
+       cp --help 2>&1 | grep 'Copy SOURCE'))
 
 $(eval $(call SetupHostCommand,seq,, \
        gseq --version, \
@@ -114,14 +124,9 @@ $(eval $(call SetupHostCommand,getopt, \
        getopt -o t --long test -- --test | grep '^ *--test *--'))
 
 $(eval $(call SetupHostCommand,stat,Cannot find a file stat utility, \
-       gnustat -c%s $(TMP_DIR)/.host.mk, \
-       gstat -c%s $(TMP_DIR)/.host.mk, \
-       stat -c%s $(TMP_DIR)/.host.mk))
-
-$(eval $(call SetupHostCommand,md5sum,, \
-       gmd5sum /dev/null | grep d41d8cd98f00b204e9800998ecf8427e, \
-       md5sum /dev/null | grep d41d8cd98f00b204e9800998ecf8427e, \
-       $(SCRIPT_DIR)/md5sum /dev/null | grep d41d8cd98f00b204e9800998ecf8427e))
+       gnustat -c%s $(TOPDIR)/Makefile, \
+       gstat -c%s $(TOPDIR)/Makefile, \
+       stat -c%s $(TOPDIR)/Makefile))
 
 $(eval $(call SetupHostCommand,unzip,Please install 'unzip', \
        unzip 2>&1 | grep zipfile, \
@@ -141,18 +146,17 @@ $(eval $(call SetupHostCommand,python,Please install Python 2.x, \
        python2 -V 2>&1 | grep Python, \
        python -V 2>&1 | grep Python))
 
-$(eval $(call SetupHostCommand,svn,Please install the Subversion client, \
-       svn --version | grep Subversion))
-
-$(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.6.5, \
-       git clone 2>&1 | grep -- --recursive))
+$(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
+       git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule))
 
 $(eval $(call SetupHostCommand,file,Please install the 'file' package, \
        file --version 2>&1 | grep file))
 
-$(eval $(call SetupHostCommand,openssl,Please install the 'openssl' utility, \
-       openssl version | grep OpenSSL))
+$(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
+       mkdir -p $(dir $@)
+       $(CC) -O2 -I$(TOPDIR)/tools/include -o $@ $<
 
+prereq: $(STAGING_DIR_HOST)/bin/mkhash
 
 # Install ldconfig stub
 $(eval $(call TestHostCommand,ldconfig-stub,Failed to install stub, \