build: reimplement package build directory override
[openwrt/openwrt.git] / include / prereq-build.mk
index f0e1da9810d2f51c934cb63e364195e77ae69f2c..b7ada69bb418ba51c3cedbc05f277a5fffb637c5 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,6 +8,7 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/prereq.mk
 include $(INCLUDE_DIR)/host.mk
+include $(INCLUDE_DIR)/host-build.mk
 
 PKG_NAME:=Build dependency
 
@@ -20,7 +21,7 @@ $(eval $(call Require,non-root, \
 
 # Required for the toolchain
 define Require/working-make
-       $(MAKE) -v | awk '($$$$1 == "GNU") && ($$$$2 = "Make") && ($$$$3 >= "3.81") { print "ok" }' | grep ok > /dev/null
+       $(MAKE) -v | awk '($$$$1 == "GNU") && ($$$$2 == "Make") && ($$$$3 >= "3.81") { print "ok" }' | grep ok > /dev/null
 endef
 
 $(eval $(call Require,working-make, \
@@ -38,6 +39,8 @@ $(eval $(call Require,case-sensitive-fs, \
 ))
 
 define Require/getopt
+       gnugetopt --help 2>&1 | grep long >/dev/null || \
+       /usr/local/bin/getopt --help 2>&1 | grep long >/dev/null || \
        getopt --help 2>&1 | grep long >/dev/null
 endef
 $(eval $(call Require,getopt, \
@@ -62,7 +65,7 @@ $(eval $(call Require,working-gcc, \
 
 define Require/working-g++
        echo 'int main(int argc, char **argv) { return 0; }' | \
-               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ - && \
+               g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \
                $(TMP_DIR)/a.out
 endef
 
@@ -70,9 +73,30 @@ $(eval $(call Require,working-g++, \
        Please install the GNU C++ Compiler (g++). \
 ))
 
+ifneq ($(HOST_STATIC_LINKING),)
+  define Require/working-gcc-static
+       echo 'int main(int argc, char **argv) { return 0; }' | \
+               gcc -x c $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out -
+  endef
+
+  $(eval $(call Require,working-gcc-static, \
+    Please install the static libc development package (glibc-static on CentOS/Fedora/RHEL). \
+  ))
+
+  define Require/working-g++-static
+       echo 'int main(int argc, char **argv) { return 0; }' | \
+               g++ -x c++ $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out - -lstdc++ && \
+               $(TMP_DIR)/a.out
+  endef
+
+  $(eval $(call Require,working-g++-static, \
+       Please install the static libstdc++ development package (libstdc++-static on CentOS/Fedora/RHEL). \
+  ))
+endif
+
 define Require/ncurses
        echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
-               gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out -lncurses -
+               gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses
 endef
 
 $(eval $(call Require,ncurses, \
@@ -82,23 +106,26 @@ $(eval $(call Require,ncurses, \
 
 define Require/zlib
        echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
-               gcc -include zlib.h -x c -o $(TMP_DIR)/a.out -lz -
+               gcc -include zlib.h -x c -o $(TMP_DIR)/a.out - -lz
 endef
 
 $(eval $(call Require,zlib, \
        Please install zlib. (Missing libz.so or zlib.h) \
 ))
 
-$(eval $(call RequireCommand,gawk, \
-       Please install GNU awk. \
-))
+ifneq ($(HOST_STATIC_LINKING),)
+  define Require/zlib-static
+       echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
+               gcc -include zlib.h -x c $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out - -lz
+  endef
 
-$(eval $(call RequireCommand,bison, \
-       Please install GNU bison. \
-))
+  $(eval $(call Require,zlib-static, \
+       Please install a static zlib. (zlib-static on CentOS/Fedora/RHEL). \
+  ))
+endif
 
-$(eval $(call RequireCommand,flex, \
-       Please install flex. \
+$(eval $(call RequireCommand,gawk, \
+       Please install GNU awk. \
 ))
 
 $(eval $(call RequireCommand,unzip, \
@@ -109,15 +136,11 @@ $(eval $(call RequireCommand,bzip2, \
        Please install bzip2. \
 ))
 
-$(eval $(call RequireCommand,patch, \
-       Please install patch. \
-))
-
 $(eval $(call RequireCommand,perl, \
        Please install perl. \
 ))
 
-$(eval $(call RequireCommand,python, \
+$(eval $(call RequireCommand,$(PYTHON), \
        Please install python. \
 ))
 
@@ -125,6 +148,14 @@ $(eval $(call RequireCommand,wget, \
        Please install wget. \
 ))
 
+define Require/git
+       git --version | awk '($$$$1 == "git") && ($$$$2 == "version") && ($$$$3 >= "1.6.5") { print "ok" }' | grep ok > /dev/null
+endef
+
+$(eval $(call Require,git, \
+       Please install git (git-core) v1.6.5 or later. \
+))
+
 define Require/gnutar
        $(TAR) --version 2>&1 | grep GNU > /dev/null
 endef
@@ -137,12 +168,12 @@ $(eval $(call RequireCommand,svn, \
        Please install the subversion client. \
 ))
 
-$(eval $(call RequireCommand,autoconf, \
-       Please install GNU autoconf. \
+$(eval $(call RequireCommand,openssl, \
+       Please install openssl. \
 ))
 
 define Require/gnu-find
-       $(FIND) $(TMP_DIR) -lname foo
+       $(FIND) --version 2>/dev/null
 endef
 
 $(eval $(call Require,gnu-find, \