build: log time taken by each packages/steps
[openwrt/openwrt.git] / include / prereq-build.mk
index 9b77a1baf70b32828aaeb6f0ace064b08fc031fc..bac5fdc84c651d29a66a52883c4ecd6caf90bb1d 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/prereq.mk
-include $(INCLUDE_DIR)/host.mk
 
+SHELL:=sh
 PKG_NAME:=Build dependency
 
-define Require/non-root
-       [ "$$(shell whoami)" != "root" ]
-endef
-$(eval $(call Require,non-root, \
-       Please do not compile as root. \
-))
 
 # Required for the toolchain
-define Require/working-make
-       echo 'all: test' > $(TMP_DIR)/check.mk
-       echo 'e0 = $$$$(foreach s,foobar,$$$$(eval $$$$s:))' >> $(TMP_DIR)/check.mk
-       echo 'e1 = $$$$(foreach s,foobar, $$$$(eval $$$$s:))' >> $(TMP_DIR)/check.mk
-       echo 'test: $$$$(strip $$$$(e0)) $$$$(strip $$$$(e1))' >> $(TMP_DIR)/check.mk
-       $(NO_TRACE_MAKE) -f $(TMP_DIR)/check.mk
-endef
-
-$(eval $(call Require,working-make, \
-       Please install GNU make v3.81 or later. (This version has bugs) \
-))
-
-define Require/case-sensitive-fs
-       rm -f $(TMP_DIR)/test.*
-       touch $(TMP_DIR)/test.fs
-       [ \! -f $(TMP_DIR)/test.FS ]
-endef
-
-$(eval $(call Require,case-sensitive-fs, \
-       OpenWrt can only be built on a case-sensitive filesystem \
-))
-
-define Require/working-gcc
+$(eval $(call TestHostCommand,working-make, \
+       Please install GNU make v3.81 or later. (This version has bugs), \
+       $(MAKE) -v | grep -E 'Make (3\.8[1-9]|3\.9[0-9]|[4-9]\.)'))
+
+$(eval $(call TestHostCommand,case-sensitive-fs, \
+       OpenWrt can only be built on a case-sensitive filesystem, \
+       rm -f $(TMP_DIR)/test.*; touch $(TMP_DIR)/test.fs; \
+               test ! -f $(TMP_DIR)/test.FS))
+
+$(eval $(call TestHostCommand,proper-umask, \
+       Please build with umask 022 - other values produce broken packages, \
+       umask | grep -xE 00[012][012]))
+
+$(eval $(call SetupHostCommand,gcc, \
+       Please install the GNU C Compiler (gcc) 4.8 or later \
+       $(CC) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
+       gcc -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
+       gcc48 --version | grep gcc, \
+       gcc49 --version | grep gcc, \
+       gcc5 --version | grep gcc, \
+       gcc6 --version | grep gcc, \
+       gcc7 --version | grep gcc, \
+       gcc8 --version | grep gcc, \
+       gcc9 --version | grep gcc, \
+       gcc --version | grep Apple.LLVM ))
+
+$(eval $(call TestHostCommand,working-gcc, \
+       \nPlease reinstall the GNU C Compiler (4.8 or later) - \
+       it appears to be broken, \
+       echo 'int main(int argc, char **argv) { return 0; }' | \
+               gcc -x c -o $(TMP_DIR)/a.out -))
+
+$(eval $(call SetupHostCommand,g++, \
+       Please install the GNU C++ Compiler (g++) 4.8 or later \
+       $(CXX) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
+       g++ -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
+       g++48 --version | grep g++, \
+       g++49 --version | grep g++, \
+       g++5 --version | grep g++, \
+       g++6 --version | grep g++, \
+       g++7 --version | grep g++, \
+       g++8 --version | grep g++, \
+       g++9 --version | grep g++, \
+       g++ --version | grep Apple.LLVM ))
+
+$(eval $(call TestHostCommand,working-g++, \
+       \nPlease reinstall the GNU C++ Compiler (4.8 or later) - \
+       it appears to be broken, \
        echo 'int main(int argc, char **argv) { return 0; }' | \
-               gcc -x c -o $(TMP_DIR)/a.out -
-endef
+               g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \
+               $(TMP_DIR)/a.out))
 
-$(eval $(call Require,working-gcc, \
-       Please install the GNU C Compiler (gcc). \
-))
+$(eval $(call TestHostCommand,ncurses, \
+       Please install ncurses. (Missing libncurses.so or ncurses.h), \
+       echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
+               gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses))
 
-define Require/working-g++
-       echo 'int main(int argc, char **argv) { return 0; }' | \
-               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ - && \
-               $(TMP_DIR)/a.out
-endef
+ifeq ($(HOST_OS),Linux)
+  zlib_link_flags := -Wl,-Bstatic -lz -Wl,-Bdynamic
+else
+  zlib_link_flags := -lz
+endif
 
-$(eval $(call Require,working-g++, \
-       Please install the GNU C++ Compiler (g++). \
-))
+$(eval $(call TestHostCommand,perl-thread-queue, \
+       Please install the Perl Thread::Queue module, \
+       perl -MThread::Queue -e 1))
 
-define Require/ncurses
-       echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
-               gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out -lncurses -
-endef
 
-$(eval $(call Require,ncurses, \
-       Please install ncurses. (Missing libncurses.so or ncurses.h) \
-))
+$(eval $(call SetupHostCommand,tar,Please install GNU 'tar', \
+       gtar --version 2>&1 | grep GNU, \
+       gnutar --version 2>&1 | grep GNU, \
+       tar --version 2>&1 | grep GNU))
+
+$(eval $(call SetupHostCommand,find,Please install GNU 'find', \
+       gfind --version 2>&1 | grep GNU, \
+       find --version 2>&1 | grep GNU))
+
+$(eval $(call SetupHostCommand,bash,Please install GNU 'bash', \
+       bash --version 2>&1 | grep GNU))
+
+$(eval $(call SetupHostCommand,patch,Please install GNU 'patch', \
+       gpatch --version 2>&1 | grep 'Free Software Foundation', \
+       patch --version 2>&1 | grep 'Free Software Foundation'))
 
+$(eval $(call SetupHostCommand,diff,Please install diffutils, \
+       gdiff --version 2>&1 | grep diff, \
+       diff --version 2>&1 | grep diff))
 
-define Require/zlib
-       echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
-               gcc -include zlib.h -x c -o $(TMP_DIR)/a.out -lz -
-endef
+$(eval $(call SetupHostCommand,cp,Please install GNU fileutils, \
+       gcp --help 2>&1 | grep 'Copy SOURCE', \
+       cp --help 2>&1 | grep 'Copy SOURCE'))
 
-$(eval $(call Require,zlib, \
-       Please install zlib. (Missing libz.so or zlib.h) \
-))
+$(eval $(call SetupHostCommand,seq,, \
+       gseq --version, \
+       seq --version))
 
-$(eval $(call RequireCommand,gawk, \
-       Please install GNU awk. \
-))
+$(eval $(call SetupHostCommand,awk,Please install GNU 'awk', \
+       gawk --version 2>&1 | grep GNU, \
+       awk --version 2>&1 | grep GNU))
 
-$(eval $(call RequireCommand,bison, \
-       Please install GNU bison. \
-))
+$(eval $(call SetupHostCommand,grep,Please install GNU 'grep', \
+       ggrep --version 2>&1 | grep GNU, \
+       grep --version 2>&1 | grep GNU))
 
-$(eval $(call RequireCommand,flex, \
-       Please install flex. \
-))
+$(eval $(call SetupHostCommand,getopt, \
+       Please install an extended getopt version that supports --long, \
+       gnugetopt -o t --long test -- --test | grep '^ *--test *--', \
+       /usr/local/bin/getopt -o t --long test -- --test | grep '^ *--test *--', \
+       getopt -o t --long test -- --test | grep '^ *--test *--'))
 
-$(eval $(call RequireCommand,unzip, \
-       Please install unzip. \
-))
+$(eval $(call SetupHostCommand,stat,Cannot find a file stat utility, \
+       gnustat -c%s $(TOPDIR)/Makefile, \
+       gstat -c%s $(TOPDIR)/Makefile, \
+       stat -c%s $(TOPDIR)/Makefile))
 
-$(eval $(call RequireCommand,bzip2, \
-       Please install bzip2. \
-))
+$(eval $(call SetupHostCommand,unzip,Please install 'unzip', \
+       unzip 2>&1 | grep zipfile, \
+       unzip))
 
-$(eval $(call RequireCommand,patch, \
-       Please install patch. \
-))
+$(eval $(call SetupHostCommand,bzip2,Please install 'bzip2', \
+       bzip2 --version </dev/null))
 
-$(eval $(call RequireCommand,perl, \
-       Please install perl. \
-))
+$(eval $(call SetupHostCommand,wget,Please install GNU 'wget', \
+       wget --version | grep GNU))
 
-$(eval $(call RequireCommand,wget, \
-       Please install wget. \
-))
+$(eval $(call SetupHostCommand,gtime,Please install GNU 'time', \
+       gtime --version 2>&1 | grep GNU, \
+       time --version 2>&1 | grep GNU))
 
-define Require/gnutar
-       $(TAR) --version 2>&1 | grep GNU > /dev/null
-endef
+$(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
+       perl --version | grep "perl.*v5"))
 
-$(eval $(call Require,gnutar, \
-       Please install GNU tar. \
-))
+$(eval $(call SetupHostCommand,python,Please install Python 2.x, \
+       python2.7 -V 2>&1 | grep Python, \
+       python2 -V 2>&1 | grep Python, \
+       python -V 2>&1 | grep Python))
 
-define Require/git
-       which git-clone
-endef
+$(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
+       git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule))
 
-$(eval $(call Require,git, \
-       Please install git. \
-))
+$(eval $(call SetupHostCommand,file,Please install the 'file' package, \
+       file --version 2>&1 | grep file))
 
-$(eval $(call RequireCommand,svn, \
-       Please install the subversion client. \
-))
+$(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
+       mkdir -p $(dir $@)
+       $(CC) -O2 -I$(TOPDIR)/tools/include -o $@ $<
 
-$(eval $(call RequireCommand,autoconf, \
-       Please install GNU autoconf. \
-))
+prereq: $(STAGING_DIR_HOST)/bin/mkhash
 
+# Install ldconfig stub
+$(eval $(call TestHostCommand,ldconfig-stub,Failed to install stub, \
+       touch $(STAGING_DIR_HOST)/bin/ldconfig && \
+       chmod +x $(STAGING_DIR_HOST)/bin/ldconfig))