add better working-g++ check (patch from #2017)
[openwrt/openwrt.git] / include / prereq-build.mk
index 7355b9e..c31020c 100644 (file)
@@ -52,7 +52,8 @@ $(eval $(call Require,working-gcc, \
 
 define Require/working-g++
        echo 'int main(int argc, char **argv) { return 0; }' | \
-               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ -
+               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ - && \
+               $(TMP_DIR)/a.out
 endef
 
 $(eval $(call Require,working-g++, \
@@ -122,10 +123,3 @@ $(eval $(call RequireCommand,autoconf, \
        Please install GNU autoconf. \
 ))
 
-define Require/find
-       find . -maxdepth 1 -exec ls {} + > /dev/null 2>&1
-endef
-
-$(eval $(call Require,find, \
-       Please install GNU find 4.2.12 or better. \
-))