add better working-g++ check (patch from #2017)
[openwrt/openwrt.git] / include / prereq-build.mk
index c73b12438fff3916441aa22a76ba4216f6aa2ebd..c31020c3211d528acca14d8d4a1a233652dfb1d6 100644 (file)
@@ -9,6 +9,8 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/prereq.mk
 include $(INCLUDE_DIR)/host.mk
 
+PKG_NAME:=Build dependency
+
 define Require/non-root
        [ "$$(shell whoami)" != "root" ]
 endef
@@ -50,7 +52,8 @@ $(eval $(call Require,working-gcc, \
 
 define Require/working-g++
        echo 'int main(int argc, char **argv) { return 0; }' | \
-               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ -
+               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ - && \
+               $(TMP_DIR)/a.out
 endef
 
 $(eval $(call Require,working-g++, \
@@ -76,6 +79,9 @@ $(eval $(call Require,zlib, \
        Please install zlib. (Missing libz.so or zlib.h) \
 ))
 
+$(eval $(call RequireCommand,gawk, \
+       Please install GNU awk. \
+))
 
 $(eval $(call RequireCommand,bison, \
        Please install GNU bison. \
@@ -117,4 +123,3 @@ $(eval $(call RequireCommand,autoconf, \
        Please install GNU autoconf. \
 ))
 
-