include: add umask prereq check
[openwrt/openwrt.git] / include / prereq-build.mk
index 9c0717d53a8beaab2cec5958fbf981d8796a17b1..c3b88db6271631e6fb5a8f720825fcb547dd7d67 100644 (file)
@@ -24,6 +24,10 @@ $(eval $(call TestHostCommand,case-sensitive-fs, \
        rm -f $(TMP_DIR)/test.*; touch $(TMP_DIR)/test.fs; \
                test ! -f $(TMP_DIR)/test.FS))
 
+$(eval $(call TestHostCommand,proper-umask, \
+       Please build with umask 022 - other values produce broken packages, \
+       umask | grep -xF 0022))
+
 $(eval $(call SetupHostCommand,gcc, \
        Please install the GNU C Compiler (gcc), \
        $(CC) --version | grep gcc, \