uqmi: bump to latest git HEAD
[openwrt/openwrt.git] / include / prereq-build.mk
index c3b88db6271631e6fb5a8f720825fcb547dd7d67..ed652ca9a729a6bd8e9222012e9ef65bea04bd21 100644 (file)
@@ -26,7 +26,7 @@ $(eval $(call TestHostCommand,case-sensitive-fs, \
 
 $(eval $(call TestHostCommand,proper-umask, \
        Please build with umask 022 - other values produce broken packages, \
-       umask | grep -xF 0022))
+       umask | grep -xE 00[012][012]))
 
 $(eval $(call SetupHostCommand,gcc, \
        Please install the GNU C Compiler (gcc), \
@@ -109,8 +109,8 @@ $(eval $(call SetupHostCommand,diff,Please install diffutils, \
        diff --version 2>&1 | grep diff))
 
 $(eval $(call SetupHostCommand,cp,Please install GNU fileutils, \
-       gcp --help, \
-       cp --help))
+       gcp --help 2>&1 | grep 'Copy SOURCE', \
+       cp --help 2>&1 | grep 'Copy SOURCE'))
 
 $(eval $(call SetupHostCommand,seq,, \
        gseq --version, \