uclient: update to Git HEAD (2024-04-19)
[openwrt/openwrt.git] / include / prereq-build.mk
index 306a6b3e38bd5855579c3f19cf2bca0cb7e35dff..49340ce3e441ccbaa1833d6eb38d8abd450f627e 100644 (file)
-# 
-# Copyright (C) 2006-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
+# SPDX-License-Identifier: GPL-2.0-only
 #
+# Copyright (C) 2006-2020 OpenWrt.org
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/prereq.mk
-include $(INCLUDE_DIR)/host.mk
-include $(INCLUDE_DIR)/host-build.mk
 
 SHELL:=sh
 PKG_NAME:=Build dependency
 
+$(eval $(call TestHostCommand,true, \
+       Please install GNU 'coreutils', \
+       $(TRUE)))
+
+$(eval $(call TestHostCommand,false, \
+       Please install GNU 'coreutils', \
+       $(FALSE); [ $$$$$$$$? = 1 ] && $(TRUE)))
 
 # Required for the toolchain
 $(eval $(call TestHostCommand,working-make, \
-       Please install GNU make v3.81 or later. (This version has bugs), \
-       $(MAKE) -v | grep -E 'Make (3\.8[1-9]|3\.9[0-9]|[4-9]\.)'))
+       Please install GNU make v4.1 or later., \
+       $(MAKE) -v | grep -E 'Make (4\.[1-9]|[5-9]\.)'))
 
 $(eval $(call TestHostCommand,case-sensitive-fs, \
        OpenWrt can only be built on a case-sensitive filesystem, \
        rm -f $(TMP_DIR)/test.*; touch $(TMP_DIR)/test.fs; \
                test ! -f $(TMP_DIR)/test.FS))
 
+$(eval $(call TestHostCommand,proper-umask, \
+       Please build with umask 022 - other values produce broken packages, \
+       umask | grep -xE 0?0[012][012]))
+
+ifndef IB
 $(eval $(call SetupHostCommand,gcc, \
-       Please install the GNU C Compiler (gcc), \
-       $(CC) --version | grep gcc, \
-       gcc --version | grep gcc, \
-       gcc49 --version | grep gcc, \
-       gcc48 --version | grep gcc, \
-       gcc47 --version | grep gcc, \
-       gcc46 --version | grep gcc))
+       Please install the GNU C Compiler (gcc) 8 or later, \
+       $(CC) -dumpversion | grep -E '^([8-9]\.?|1[0-9]\.?)', \
+       gcc -dumpversion | grep -E '^([8-9]\.?|1[0-9]\.?)', \
+       gcc-8 -dumpversion | grep -E '^([8-9]\.?|1[0-9]\.?)', \
+       gcc --version | grep -E 'Apple.(LLVM|clang)' ))
 
 $(eval $(call TestHostCommand,working-gcc, \
-       Please reinstall the GNU C Compiler - it appears to be broken, \
+       Please reinstall the GNU C Compiler (8 or later) - \
+       it appears to be broken, \
        echo 'int main(int argc, char **argv) { return 0; }' | \
-               gcc -x c -o $(TMP_DIR)/a.out -))
+               $(STAGING_DIR_HOST)/bin/gcc -x c -o $(TMP_DIR)/a.out -))
 
 $(eval $(call SetupHostCommand,g++, \
-       Please install the GNU C++ Compiler (g++), \
-       $(CXX) --version | grep g++, \
-       g++ --version | grep g++, \
-       g++49 --version | grep g++, \
-       g++48 --version | grep g++, \
-       g++47 --version | grep g++, \
-       g++46 --version | grep g++))
+       Please install the GNU C++ Compiler (g++) 8 or later, \
+       $(CXX) -dumpversion | grep -E '^([8-9]\.?|1[0-9]\.?)', \
+       g++ -dumpversion | grep -E '^([8-9]\.?|1[0-9]\.?)', \
+       g++-8 -dumpversion | grep -E '^([8-9]\.?|1[0-9]\.?)', \
+       g++ --version | grep -E 'Apple.(LLVM|clang)' ))
 
 $(eval $(call TestHostCommand,working-g++, \
-       Please reinstall the GNU C++ Compiler - it appears to be broken, \
+       Please reinstall the GNU C++ Compiler (8 or later) - \
+       it appears to be broken, \
        echo 'int main(int argc, char **argv) { return 0; }' | \
-               g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \
+               $(STAGING_DIR_HOST)/bin/g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \
                $(TMP_DIR)/a.out))
 
-$(eval $(call TestHostCommand,ncurses, \
+$(eval $(call RequireCHeader,ncurses.h, \
        Please install ncurses. (Missing libncurses.so or ncurses.h), \
-       echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
-               gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses))
-
-$(eval $(call TestHostCommand,zlib, \
-       Please install zlib. (Missing libz.so or zlib.h), \
-       echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
-               gcc -include zlib.h -x c -o $(TMP_DIR)/a.out - -lz))
-
-$(eval $(call TestHostCommand,libssl, \
-       Please install the openssl library (with development headers), \
-       echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
-               gcc -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl))
-
-ifneq ($(HOST_STATIC_LINKING),)
-  $(eval $(call TestHostCommand,working-gcc-static, \
-       Please install the static libc development package (glibc-static on CentOS/Fedora/RHEL)., \
-       echo 'int main(int argc, char **argv) { return 0; }' | \
-               gcc -x c $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out -))
+       initscr(), -lncurses))
 
-  $(eval $(call TestHostCommand,working-g++-static, \
-       Please install the static libstdc++ development package (libstdc++-static on CentOS/Fedora/RHEL)., \
-       echo 'int main(int argc, char **argv) { return 0; }' | \
-               g++ -x c++ $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out - -lstdc++ && \
-               $(TMP_DIR)/a.out))
+$(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
+       git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule, \
+       git submodule --help | grep -- --recursive))
 
-  $(eval $(call TestHostCommand,zlib-static, \
-       Please install a static zlib. (zlib-static on CentOS/Fedora/RHEL)., \
-       echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
-               gcc -include zlib.h -x c $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out - -lz))
+$(eval $(call SetupHostCommand,rsync,Please install 'rsync', \
+       rsync --version </dev/null))
+endif # IB
+
+ifeq ($(HOST_OS),Linux)
+  zlib_link_flags := -Wl,-Bstatic -lz -Wl,-Bdynamic
+else
+  zlib_link_flags := -lz
 endif
 
+$(eval $(call TestHostCommand,perl-data-dumper, \
+       Please install the Perl Data::Dumper module, \
+       perl -MData::Dumper -e 1))
+
+$(eval $(call TestHostCommand,perl-findbin, \
+       Please install the Perl FindBin module, \
+       perl -MFindBin -e 1))
+
+$(eval $(call TestHostCommand,perl-file-copy, \
+       Please install the Perl File::Copy module, \
+       perl -MFile::Copy -e 1))
+
+$(eval $(call TestHostCommand,perl-file-compare, \
+       Please install the Perl File::Compare module, \
+       perl -MFile::Compare -e 1))
+
+$(eval $(call TestHostCommand,perl-thread-queue, \
+       Please install the Perl Thread::Queue module, \
+       perl -MThread::Queue -e 1))
+
+$(eval $(call TestHostCommand,perl-ipc-cmd, \
+       Please install the Perl IPC:Cmd module, \
+       perl -MIPC::Cmd -e 1))
 
 $(eval $(call SetupHostCommand,tar,Please install GNU 'tar', \
        gtar --version 2>&1 | grep GNU, \
@@ -99,21 +112,26 @@ $(eval $(call SetupHostCommand,find,Please install GNU 'find', \
 $(eval $(call SetupHostCommand,bash,Please install GNU 'bash', \
        bash --version 2>&1 | grep GNU))
 
+$(eval $(call SetupHostCommand,xargs, \
+       Please install 'xargs' that supports '-r/--no-run-if-empty', \
+       gxargs -r --version, \
+       xargs -r --version))
+
 $(eval $(call SetupHostCommand,patch,Please install GNU 'patch', \
        gpatch --version 2>&1 | grep 'Free Software Foundation', \
        patch --version 2>&1 | grep 'Free Software Foundation'))
 
-$(eval $(call SetupHostCommand,diff,Please install diffutils, \
-       gdiff --version 2>&1 | grep diff, \
-       diff --version 2>&1 | grep diff))
+$(eval $(call SetupHostCommand,diff,Please install GNU diffutils, \
+       gdiff --version 2>&1 | grep GNU, \
+       diff --version 2>&1 | grep GNU))
 
 $(eval $(call SetupHostCommand,cp,Please install GNU fileutils, \
-       gcp --help, \
-       cp --help))
+       gcp --help 2>&1 | grep 'Copy SOURCE', \
+       cp --help 2>&1 | grep 'Copy SOURCE'))
 
-$(eval $(call SetupHostCommand,seq,, \
+$(eval $(call SetupHostCommand,seq,Please install seq, \
        gseq --version, \
-       seq --version))
+       seq --version 2>&1 | grep seq))
 
 $(eval $(call SetupHostCommand,awk,Please install GNU 'awk', \
        gawk --version 2>&1 | grep GNU, \
@@ -123,21 +141,28 @@ $(eval $(call SetupHostCommand,grep,Please install GNU 'grep', \
        ggrep --version 2>&1 | grep GNU, \
        grep --version 2>&1 | grep GNU))
 
+$(eval $(call SetupHostCommand,egrep,Please install GNU 'grep', \
+       gegrep --version 2>&1 | grep GNU, \
+       egrep --version 2>&1 | grep GNU))
+
 $(eval $(call SetupHostCommand,getopt, \
        Please install an extended getopt version that supports --long, \
        gnugetopt -o t --long test -- --test | grep '^ *--test *--', \
-       /usr/local/bin/getopt -o t --long test -- --test | grep '^ *--test *--', \
-       getopt -o t --long test -- --test | grep '^ *--test *--'))
+       getopt -o t --long test -- --test | grep '^ *--test *--', \
+       /usr/local/opt/gnu-getopt/bin/getopt -o t --long test -- --test | grep '^ *--test *--', \
+       /opt/local/bin/getopt -o t --long test -- --test | grep '^ *--test *--'))
+
+$(eval $(call SetupHostCommand,realpath,Please install a 'realpath' utility, \
+       grealpath /, \
+       realpath /))
 
 $(eval $(call SetupHostCommand,stat,Cannot find a file stat utility, \
-       gnustat -c%s $(TMP_DIR)/.host.mk, \
-       gstat -c%s $(TMP_DIR)/.host.mk, \
-       stat -c%s $(TMP_DIR)/.host.mk))
+       gnustat -c%s $(TOPDIR)/Makefile, \
+       gstat -c%s $(TOPDIR)/Makefile, \
+       stat -c%s $(TOPDIR)/Makefile))
 
-$(eval $(call SetupHostCommand,md5sum,, \
-       gmd5sum /dev/null | grep d41d8cd98f00b204e9800998ecf8427e, \
-       md5sum /dev/null | grep d41d8cd98f00b204e9800998ecf8427e, \
-       $(SCRIPT_DIR)/md5sum /dev/null | grep d41d8cd98f00b204e9800998ecf8427e))
+$(eval $(call SetupHostCommand,gzip,Please install 'gzip', \
+       gzip --version </dev/null))
 
 $(eval $(call SetupHostCommand,unzip,Please install 'unzip', \
        unzip 2>&1 | grep zipfile, \
@@ -149,28 +174,68 @@ $(eval $(call SetupHostCommand,bzip2,Please install 'bzip2', \
 $(eval $(call SetupHostCommand,wget,Please install GNU 'wget', \
        wget --version | grep GNU))
 
+$(eval $(call SetupHostCommand,install,Please install GNU 'install', \
+       install --version | grep GNU, \
+       ginstall --version | grep GNU))
+
 $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
-       perl --version | grep "perl 5"))
+       perl --version | grep "perl.*v5"))
+
+$(eval $(call SetupHostCommand,python,Please install Python >= 3.7, \
+       python3.11 -V 2>&1 | grep 'Python 3', \
+       python3.10 -V 2>&1 | grep 'Python 3', \
+       python3.9 -V 2>&1 | grep 'Python 3', \
+       python3.8 -V 2>&1 | grep 'Python 3', \
+       python3.7 -V 2>&1 | grep 'Python 3', \
+       python3 -V 2>&1 | grep -E 'Python 3\.([7-9]|[0-9][0-9])\.?'))
+
+$(eval $(call SetupHostCommand,python3,Please install Python >= 3.7, \
+       python3.11 -V 2>&1 | grep 'Python 3', \
+       python3.10 -V 2>&1 | grep 'Python 3', \
+       python3.9 -V 2>&1 | grep 'Python 3', \
+       python3.8 -V 2>&1 | grep 'Python 3', \
+       python3.7 -V 2>&1 | grep 'Python 3', \
+       python3 -V 2>&1 | grep -E 'Python 3\.([7-9]|[0-9][0-9])\.?'))
+
+$(eval $(call TestHostCommand,python3-distutils, \
+       Please install the Python3 distutils module, \
+       $(STAGING_DIR_HOST)/bin/python3 -c 'from distutils import util'))
+
+$(eval $(call TestHostCommand,python3-stdlib, \
+       Please install the Python3 stdlib module, \
+       $(STAGING_DIR_HOST)/bin/python3 -c 'import ntpath'))
 
-$(eval $(call SetupHostCommand,python,Please install Python 2.x, \
-       python2.7 -V 2>&1 | grep Python, \
-       python2 -V 2>&1 | grep Python, \
-       python -V 2>&1 | grep Python))
+$(eval $(call SetupHostCommand,file,Please install the 'file' package, \
+       file --version 2>&1 | grep file))
 
-$(eval $(call SetupHostCommand,svn,Please install the Subversion client, \
-       svn --version | grep Subversion))
+$(eval $(call SetupHostCommand,which,Please install 'which', \
+       /usr/bin/which which, \
+       /bin/which which, \
+       which which))
 
-$(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.6.5, \
-       git clone --help | grep -- --recursive))
+ifeq ($(HOST_OS),Linux)
+  $(eval $(call RequireCHeader,argp.h, \
+       Missing argp.h Please install the argp-standalone package if musl libc))
 
-$(eval $(call SetupHostCommand,file,Please install the 'file' package, \
-       file --version | grep file))
+  $(eval $(call RequireCHeader,fts.h, \
+       Missing fts.h Please install the musl-fts-dev package if musl libc))
+
+  $(eval $(call RequireCHeader,obstack.h, \
+       Missing obstack.h Please install the musl-obstack-dev package if musl libc))
+
+  $(eval $(call RequireCHeader,libintl.h, \
+       Missing libintl.h Please install the musl-libintl package if musl libc))
+endif
+
+$(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
+       mkdir -p $(dir $@)
+       $(CC) -O2 -I$(TOPDIR)/tools/include -o $@ $<
 
-$(eval $(call SetupHostCommand,openssl,Please install the 'openssl' utility, \
-       openssl version | grep OpenSSL))
+$(STAGING_DIR_HOST)/bin/xxd: $(SCRIPT_DIR)/xxdi.pl
+       $(LN) $< $@
 
+prereq: $(STAGING_DIR_HOST)/bin/mkhash $(STAGING_DIR_HOST)/bin/xxd
 
 # Install ldconfig stub
 $(eval $(call TestHostCommand,ldconfig-stub,Failed to install stub, \
-       touch $(STAGING_DIR_HOST)/bin/ldconfig && \
-       chmod +x $(STAGING_DIR_HOST)/bin/ldconfig))
+       $(LN) $(SCRIPT_DIR)/noop.sh $(STAGING_DIR_HOST)/bin/ldconfig))