ar71xx: fix Arduino Yun enabling of level shifters outputs
[openwrt/openwrt.git] / include / prereq-build.mk
index d7562b4f72cbb420c59401c8e5d376c7698877c2..f7da916f648c5c67f73938308fe2df26177204bb 100644 (file)
@@ -18,23 +18,25 @@ $(eval $(call TestHostCommand,working-make, \
        $(MAKE) -v | grep -E 'Make (3\.8[1-9]|3\.9[0-9]|[4-9]\.)'))
 
 $(eval $(call TestHostCommand,case-sensitive-fs, \
-       LEDE can only be built on a case-sensitive filesystem, \
+       OpenWrt can only be built on a case-sensitive filesystem, \
        rm -f $(TMP_DIR)/test.*; touch $(TMP_DIR)/test.fs; \
                test ! -f $(TMP_DIR)/test.FS))
 
 $(eval $(call TestHostCommand,proper-umask, \
        Please build with umask 022 - other values produce broken packages, \
-       umask | grep -xE 00[012][012]))
+       umask | grep -xE 0?0[012][012]))
 
 $(eval $(call SetupHostCommand,gcc, \
-       Please install the GNU C Compiler (gcc) 4.8 or later \
-       $(CC) -dumpversion | grep -E '(4\.[8-9]|5\.?[0-9]?|6\.?[0-9]?|7\.?[0-9]?)', \
-       gcc -dumpversion | grep -E '(4\.[8-9]|5\.?[0-9]?|6\.?[0-9]?|7\.?[0-9]?)', \
+       Please install the GNU C Compiler (gcc) 4.8 or later, \
+       $(CC) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
+       gcc -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
        gcc48 --version | grep gcc, \
        gcc49 --version | grep gcc, \
        gcc5 --version | grep gcc, \
        gcc6 --version | grep gcc, \
        gcc7 --version | grep gcc, \
+       gcc8 --version | grep gcc, \
+       gcc9 --version | grep gcc, \
        gcc --version | grep Apple.LLVM ))
 
 $(eval $(call TestHostCommand,working-gcc, \
@@ -44,14 +46,16 @@ $(eval $(call TestHostCommand,working-gcc, \
                gcc -x c -o $(TMP_DIR)/a.out -))
 
 $(eval $(call SetupHostCommand,g++, \
-       Please install the GNU C++ Compiler (g++) 4.8 or later \
-       $(CXX) -dumpversion | grep -E '(4\.[8-9]|5\.?[0-9]?|6\.?[0-9]?|7\.?[0-9]?)', \
-       g++ -dumpversion | grep -E '(4\.[8-9]|5\.?[0-9]?|6\.?[0-9]?|7\.?[0-9]?)', \
+       Please install the GNU C++ Compiler (g++) 4.8 or later, \
+       $(CXX) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
+       g++ -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
        g++48 --version | grep g++, \
        g++49 --version | grep g++, \
        g++5 --version | grep g++, \
        g++6 --version | grep g++, \
        g++7 --version | grep g++, \
+       g++8 --version | grep g++, \
+       g++9 --version | grep g++, \
        g++ --version | grep Apple.LLVM ))
 
 $(eval $(call TestHostCommand,working-g++, \
@@ -72,11 +76,6 @@ else
   zlib_link_flags := -lz
 endif
 
-$(eval $(call TestHostCommand,zlib, \
-       Please install a static zlib. (Missing libz.a or zlib.h), \
-       echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
-               gcc -include zlib.h -x c -o $(TMP_DIR)/a.out - $(zlib_link_flags)))
-
 $(eval $(call TestHostCommand,perl-thread-queue, \
        Please install the Perl Thread::Queue module, \
        perl -MThread::Queue -e 1))