verbose.mk: quote SUBMAKE options
[openwrt/openwrt.git] / include / prereq.mk
index 83625e3bf2de08355d32b18d65979601b7ac17c9..0f0f2537448f2f314a4b923d0f3fb3f4924f4397 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -30,12 +30,12 @@ define Require
     prereq: prereq-$(1)
 
     prereq-$(1): $(if $(PREREQ_PREV),prereq-$(PREREQ_PREV)) FORCE
-               echo -n "Checking '$(1)'... "
+               printf "Checking '$(1)'... "
                if $(NO_TRACE_MAKE) -f $(firstword $(MAKEFILE_LIST)) check-$(1) >/dev/null 2>/dev/null; then \
                        echo 'ok.'; \
                else \
                        echo 'failed.'; \
-                       echo -e "$(PKG_NAME): $(strip $(2))" >> $(TMP_DIR)/.prereq-error; \
+                       echo "$(PKG_NAME): $(strip $(2))" >> $(TMP_DIR)/.prereq-error; \
                fi
 
     check-$(1): FORCE
@@ -62,7 +62,7 @@ define RequireHeader
   define Require/$(1)
     [ -e "$(1)" ]
   endef
-  
+
   $$(eval $$(call Require,$(1),$(2)))
 endef
 
@@ -86,9 +86,12 @@ endef
 # 3+: candidates
 define SetupHostCommand
   define Require/$(1)
+       [ -f "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0; \
        for cmd in $(call QuoteHostCommand,$(3)) $(call QuoteHostCommand,$(4)) \
                   $(call QuoteHostCommand,$(5)) $(call QuoteHostCommand,$(6)) \
-                  $(call QuoteHostCommand,$(7)) $(call QuoteHostCommand,$(8)); do \
+                  $(call QuoteHostCommand,$(7)) $(call QuoteHostCommand,$(8)) \
+                  $(call QuoteHostCommand,$(9)) $(call QuoteHostCommand,$(10)) \
+                  $(call QuoteHostCommand,$(11)) $(call QuoteHostCommand,$(12)); do \
                if [ -n "$$$$$$$$cmd" ]; then \
                        bin="$$$$$$$$(PATH="$(subst $(space),:,$(filter-out $(STAGING_DIR_HOST)/%,$(subst :,$(space),$(PATH))))" \
                                which "$$$$$$$${cmd%% *}")"; \