image.mk: force rebuild of kernel dependent parts - fixes auto-rebuild on DTS changes
[openwrt/openwrt.git] / include / quilt.mk
index 358b64ba0afd91d77d2427c58e85f0c725a07efd..3377eb105533fbbcf16144d121613ce59d42d680 100644 (file)
@@ -1,11 +1,10 @@
-# 
+#
 # Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
-#
 
-ifneq ($(__quilt_inc),1)
+ifneq ($(if $(DUMP),1,$(__quilt_inc)),1)
 __quilt_inc:=1
 
 ifeq ($(TARGET_BUILD),1)
@@ -13,6 +12,8 @@ ifeq ($(TARGET_BUILD),1)
 endif
 PATCH_DIR?=./patches
 FILES_DIR?=./files
+HOST_PATCH_DIR?=$(PATCH_DIR)
+HOST_FILES_DIR?=$(FILES_DIR)
 
 ifeq ($(MAKECMDGOALS),refresh)
   override QUILT=1
@@ -25,27 +26,26 @@ sed -e s,\\\#.*,, $(1) | grep -E \[a-zA-Z0-9\]
 endef
 
 define PatchDir/Quilt
+       @mkdir -p "$(1)/patches$(if $(3),/$(patsubst %/,%,$(3)))"
        @if [ -s "$(2)/series" ]; then \
                mkdir -p "$(1)/patches/$(3)"; \
                cp "$(2)/series" "$(1)/patches/$(3)"; \
        fi
-       @for patch in $$$$( (cd "$(2)" && if [ -f series ]; then $(call filter_series,series); else ls; fi; ) 2>/dev/null ); do ( \
-               cp "$(2)/$$$$patch" "$(1)"; \
-               cd "$(1)"; \
-               $(QUILT_CMD) import -P$(3)$$$$patch -p 1 "$$$$patch"; \
-               $(QUILT_CMD) push -f >/dev/null 2>/dev/null; \
-               rm -f "$$$$patch"; \
+       @for patch in $$$$( (cd "$(2)" && if [ -f series ]; then $(call filter_series,series); else ls | sort; fi; ) 2>/dev/null ); do ( \
+               cp "$(2)/$$$$patch" "$(1)/patches/$(3)"; \
+               echo "$(3)$$$$patch" >> "$(1)/patches/series"; \
        ); done
        $(if $(3),@echo $(3) >> "$(1)/patches/.subdirs")
 endef
 
 define PatchDir/Default
-       @if [ -d "$(2)" -a "$$$$(ls $(2) | wc -l)" -gt 0 ]; then \
+       @if [ -d "$(2)" ] && [ "$$$$(ls $(2) | wc -l)" -gt 0 ]; then \
+               export PATCH="$(PATCH)"; \
                if [ -s "$(2)/series" ]; then \
                        $(call filter_series,$(2)/series) | xargs -n1 \
-                               $(PATCH) "$(1)" "$(2)"; \
+                               $(KPATCH) "$(1)" "$(2)"; \
                else \
-                       $(PATCH) "$(1)" "$(2)"; \
+                       $(KPATCH) "$(1)" "$(2)"; \
                fi; \
        fi
 endef
@@ -54,36 +54,38 @@ define PatchDir
 $(call PatchDir/$(if $(strip $(QUILT)),Quilt,Default),$(strip $(1)),$(strip $(2)),$(strip $(3)))
 endef
 
+define HostPatchDir
+$(call PatchDir/$(if $(strip $(HOST_QUILT)),Quilt,Default),$(strip $(1)),$(strip $(2)),$(strip $(3)))
+endef
+
 ifneq ($(PKG_BUILD_DIR),)
-  QUILT?=$(strip $(shell test -f $(PKG_BUILD_DIR)/.quilt_used && echo y))
+  QUILT?=$(if $(wildcard $(PKG_BUILD_DIR)/.quilt_used),y)
   ifneq ($(QUILT),)
-    STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
     STAMP_CHECKED:=$(PKG_BUILD_DIR)/.quilt_checked
     override CONFIG_AUTOREBUILD=
-    prepare: $(STAMP_PATCHED)
     quilt-check: $(STAMP_CHECKED)
   endif
 endif
 
 ifneq ($(HOST_BUILD_DIR),)
-  HOST_QUILT?=$(strip $(shell test -f $(if $(PKG_BUILD_DIR),$(PKG_BUILD_DIR),$(HOST_BUILD_DIR))/.quilt_used && echo y))
+  HOST_QUILT?=$(if $(findstring command,$(origin QUILT)),$(QUILT),$(if $(wildcard $(HOST_BUILD_DIR)/.quilt_used),y))
   ifneq ($(HOST_QUILT),)
-    HOST_STAMP_PATCHED:=$(HOST_BUILD_DIR)/.quilt_patched
     HOST_STAMP_CHECKED:=$(HOST_BUILD_DIR)/.quilt_checked
     override CONFIG_AUTOREBUILD=
-    host-prepare: $(HOST_STAMP_PATCHED)
     host-quilt-check: $(HOST_STAMP_CHECKED)
   endif
 endif
 
 define Host/Patch/Default
-       $(if $(QUILT),rm -rf $(HOST_BUILD_DIR)/patches; mkdir -p $(HOST_BUILD_DIR)/patches)
-       $(call PatchDir,$(HOST_BUILD_DIR),$(PATCH_DIR),)
+       $(if $(HOST_QUILT),rm -rf $(HOST_BUILD_DIR)/patches; mkdir -p $(HOST_BUILD_DIR)/patches)
+       $(call HostPatchDir,$(HOST_BUILD_DIR),$(HOST_PATCH_DIR),)
+       $(if $(HOST_QUILT),touch $(HOST_BUILD_DIR)/.quilt_used)
 endef
 
 define Build/Patch/Default
        $(if $(QUILT),rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches)
        $(call PatchDir,$(PKG_BUILD_DIR),$(PATCH_DIR),)
+       $(if $(QUILT),touch $(PKG_BUILD_DIR)/.quilt_used)
 endef
 
 kernel_files=$(foreach fdir,$(GENERIC_FILES_DIR) $(FILES_DIR),$(fdir)/.)
@@ -99,8 +101,8 @@ define Quilt/RefreshDir
        mkdir -p $(2)
        -rm -f $(2)/* 2>/dev/null >/dev/null
        @( \
-               for patch in $$$$($(if $(3),grep "^$(3)",cat) $(PKG_BUILD_DIR)/patches/series | awk '{print $$$$1}'); do \
-                       $(CP) -v "$(PKG_BUILD_DIR)/patches/$$$$patch" $(2); \
+               for patch in $$$$($(if $(3),grep "^$(3)",cat) $(1)/patches/series | awk '{print $$$$1}'); do \
+                       $(CP) -v "$(1)/patches/$$$$patch" $(2); \
                done; \
        )
 endef
@@ -122,30 +124,10 @@ define Quilt/Refresh/Kernel
        $(call Quilt/RefreshDir,$(PKG_BUILD_DIR),$(PATCH_DIR),platform/)
 endef
 
-define Build/Quilt
-  $($(2)STAMP_PATCHED): $($(2)STAMP_PREPARED)
-       @( \
-               cd $(1)/patches; \
-               $(QUILT_CMD) pop -a -f >/dev/null 2>/dev/null; \
-               if [ -s ".subdirs" ]; then \
-                       rm -f series; \
-                       for file in $$$$(cat .subdirs); do \
-                               if [ -f $$$$file/series ]; then \
-                                       echo "Converting $$file/series"; \
-                                       $$(call filter_series,$$$$file/series) | awk -v file="$$$$file/" '$$$$0 !~ /^#/ { print file $$$$0 }' | sed -e s,//,/,g >> series; \
-                               else \
-                                       echo "Sorting patches in $$$$file"; \
-                                       find $$$$file/* -type f \! -name series | sed -e s,//,/,g | sort >> series; \
-                               fi; \
-                       done; \
-               else \
-                       find * -type f \! -name series | sort > series; \
-               fi; \
-       )
-       touch "$$@"
-
-  $($(2)STAMP_CONFIGURED): $($(2)STAMP_CHECKED) FORCE
-  $($(2)STAMP_CHECKED): $($(2)STAMP_PATCHED)
+define Quilt/Template
+  $($(2)STAMP_CONFIGURED): $($(2)STAMP_CHECKED)
+  $(if $(NO_RECONFIGURE),$($(2)STAMP_BUILT),$($(2)STAMP_CONFIGURED)): FORCE
+  $($(2)STAMP_CHECKED): $($(2)STAMP_PREPARED)
        if [ -s "$(1)/patches/series" ]; then \
                (cd "$(1)"; \
                        if $(QUILT_CMD) next >/dev/null 2>&1; then \