make sure quilt starts with the correct patch order in series
[openwrt/openwrt.git] / include / quilt.mk
index e77e0db77215f910edfe0c7fb01161e8b705261d..47195293e881df9b28fe9b0faa5a56956d16cc9e 100644 (file)
@@ -32,8 +32,9 @@ ifneq ($(QUILT),)
        @echo
        touch $(PKG_BUILD_DIR)/.quilt_used
   endef
-  $(STAMP_CONFIGURED): $(STAMP_PATCHED)
+  $(STAMP_CONFIGURED): $(STAMP_PATCHED) FORCE
   prepare: $(STAMP_PATCHED)
+  quilt-check: $(STAMP_PATCHED)
 else
   define Build/Patch/Default
        @if [ -d ./patches -a "$$$$(ls ./patches | wc -l)" -gt 0 ]; then \
@@ -45,16 +46,21 @@ endif
 define Kernel/Patch/Default
        if [ -d $(GENERIC_PLATFORM_DIR)/files ]; then $(CP) $(GENERIC_PLATFORM_DIR)/files/* $(LINUX_DIR)/; fi
        if [ -d ./files ]; then $(CP) ./files/* $(LINUX_DIR)/; fi
-       $(if $(strip $(QUILT)),$(call Quilt/Patch,$(GENERIC_PLATFORM_DIR)/patches,generic/), \
-               if [ -d $(GENERIC_PLATFORM_DIR)/patches ]; then $(PATCH) $(LINUX_DIR) $(GENERIC_PLATFORM_DIR)/patches; fi \
+       $(if $(strip $(QUILT)),$(call Quilt/Patch,$(GENERIC_PATCH_DIR),generic/), \
+               if [ -d $(GENERIC_PATCH_DIR) ]; then $(PATCH) $(LINUX_DIR) $(GENERIC_PATCH_DIR); fi \
        )
-       $(if $(strip $(QUILT)),$(call Quilt/Patch,./patches,platform/), \
-               if [ -d ./files ]; then $(CP) ./files/* $(LINUX_DIR)/; fi \
+       $(if $(strip $(QUILT)),$(call Quilt/Patch,$(PATCH_DIR),platform/), \
+               if [ -d $(PATCH_DIR) ]; then $(PATCH) $(LINUX_DIR) $(PATCH_DIR); fi \
        )
+       $(if $(strip $(QUILT)),touch $(PKG_BUILD_DIR)/.quilt_used)
 endef
 
 $(STAMP_PATCHED): $(STAMP_PREPARED)
        @cd $(PKG_BUILD_DIR); quilt pop -a -f >/dev/null 2>/dev/null || true
+       (\
+               cd $(PKG_BUILD_DIR)/patches; \
+               find * -type f \! -name series | sort > series; \
+       )
        [ -f "$(PKG_BUILD_DIR)/patches/series" ] && cd $(PKG_BUILD_DIR); quilt push -a
        touch $@
 
@@ -77,11 +83,11 @@ define Quilt/Refresh/Kernel
                echo "All kernel patches must start with either generic/ or platform/"; \
                false; \
        }
-       $(call Quilt/RefreshDir,$(GENERIC_PLATFORM_DIR)/patches,generic/)
-       $(call Quilt/RefreshDir,./patches,platform/)
+       $(call Quilt/RefreshDir,$(GENERIC_PATCH_DIR),generic/)
+       $(call Quilt/RefreshDir,$(PATCH_DIR),platform/)
 endef
 
-refresh: $(STAMP_PREPARED)
+quilt-check: $(STAMP_PREPARED) FORCE
        @[ -f "$(PKG_BUILD_DIR)/.quilt_used" ] || { \
                echo "The source directory was not unpacked using quilt. Please rebuild with QUILT=1"; \
                false; \
@@ -94,5 +100,14 @@ refresh: $(STAMP_PREPARED)
                echo "The patches are not sorted in the right order. Please fix."; \
                false; \
        }
+
+refresh: quilt-check
+       @cd $(PKG_BUILD_DIR); quilt pop -a -f >/dev/null 2>/dev/null
+       @cd $(PKG_BUILD_DIR); while quilt next 2>/dev/null >/dev/null && quilt push; do \
+               quilt refresh; \
+       done; ! quilt next 2>/dev/null >/dev/null
+       $(if $(KERNEL_BUILD),$(Quilt/Refresh/Kernel),$(Quilt/Refresh/Package))
+       
+update: quilt-check
        $(if $(KERNEL_BUILD),$(Quilt/Refresh/Kernel),$(Quilt/Refresh/Package))