netfilter: workaround a userspace/kernel mismatch on Linux 2.6.35 and later
[openwrt/openwrt.git] / include / quilt.mk
index c1f7bacd3b1f4f1bd1247857f1bc049d405bbb3c..9691dc3276c68dc8664ac38bd73d7c6afff1e628 100644 (file)
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
-#
 
-ifeq ($(KERNEL_BUILD),1)
+ifneq ($(if $(DUMP),1,$(__quilt_inc)),1)
+__quilt_inc:=1
+
+ifeq ($(TARGET_BUILD),1)
   PKG_BUILD_DIR:=$(LINUX_DIR)
 endif
 PATCH_DIR?=./patches
+FILES_DIR?=./files
+HOST_PATCH_DIR?=$(PATCH_DIR)
+HOST_FILES_DIR?=$(FILES_DIR)
+
+ifeq ($(MAKECMDGOALS),refresh)
+  override QUILT=1
+endif
 
-define Quilt/Patch
-       @for patch in $$$$( (cd $(1) && ls) 2>/dev/null ); do ( \
-               cp "$(1)/$$$$patch" $(PKG_BUILD_DIR); \
-               cd $(PKG_BUILD_DIR); \
-               quilt import -P$(2)$$$$patch -p 1 "$$$$patch"; \
-               quilt push -f >/dev/null 2>/dev/null; \
-               rm -f "$$$$patch"; \
+QUILT_CMD:=quilt --quiltrc=-
+
+define filter_series
+sed -e s,\\\#.*,, $(1) | grep -E \[a-zA-Z0-9\]
+endef
+
+define PatchDir/Quilt
+       @mkdir -p "$(1)/patches$(if $(3),/$(patsubst %/,%,$(3)))"
+       @if [ -s "$(2)/series" ]; then \
+               mkdir -p "$(1)/patches/$(3)"; \
+               cp "$(2)/series" "$(1)/patches/$(3)"; \
+       fi
+       @for patch in $$$$( (cd "$(2)" && if [ -f series ]; then $(call filter_series,series); else ls | sort; fi; ) 2>/dev/null ); do ( \
+               cp "$(2)/$$$$patch" "$(1)/patches/$(3)"; \
+               echo "$(3)$$$$patch" >> "$(1)/patches/series"; \
        ); done
+       $(if $(3),@echo $(3) >> "$(1)/patches/.subdirs")
 endef
 
-QUILT?=$(strip $(shell test -f $(PKG_BUILD_DIR)/.quilt_used && echo y))
-ifneq ($(QUILT),)
-  STAMP_PREPARED:=$(strip $(STAMP_PREPARED))_q
-  STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
-  CONFIG_AUTOREBUILD=
-  PATCHES:=$(shell )
-  define Build/Patch/Default
-       rm -rf $(PKG_BUILD_DIR)/patches
-       mkdir -p $(PKG_BUILD_DIR)/patches
-       $(call Quilt/Patch,$(PATCH_DIR),)
-       @echo
-       touch $(PKG_BUILD_DIR)/.quilt_used
-  endef
-  $(STAMP_CONFIGURED): $(STAMP_PATCHED) FORCE
-  prepare: $(STAMP_PATCHED)
-  quilt-check: $(STAMP_PATCHED)
-else
-  define Build/Patch/Default
-       @if [ -d $(PATCH_DIR) -a "$$$$(ls $(PATCH_DIR) | wc -l)" -gt 0 ]; then \
-               $(PATCH) $(PKG_BUILD_DIR) $(PATCH_DIR); \
+define PatchDir/Default
+       @if [ -d "$(2)" -a "$$$$(ls $(2) | wc -l)" -gt 0 ]; then \
+               export PATCH="$(PATCH)"; \
+               if [ -s "$(2)/series" ]; then \
+                       $(call filter_series,$(2)/series) | xargs -n1 \
+                               $(KPATCH) "$(1)" "$(2)"; \
+               else \
+                       $(KPATCH) "$(1)" "$(2)"; \
+               fi; \
        fi
-  endef
+endef
+
+define PatchDir
+$(call PatchDir/$(if $(strip $(QUILT)),Quilt,Default),$(strip $(1)),$(strip $(2)),$(strip $(3)))
+endef
+
+define HostPatchDir
+$(call PatchDir/$(if $(strip $(HOST_QUILT)),Quilt,Default),$(strip $(1)),$(strip $(2)),$(strip $(3)))
+endef
+
+ifneq ($(PKG_BUILD_DIR),)
+  QUILT?=$(if $(wildcard $(PKG_BUILD_DIR)/.quilt_used),y)
+  ifneq ($(QUILT),)
+    STAMP_CHECKED:=$(PKG_BUILD_DIR)/.quilt_checked
+    override CONFIG_AUTOREBUILD=
+    quilt-check: $(STAMP_CHECKED)
+  endif
 endif
 
-define Kernel/Patch/Default
-       if [ -d $(GENERIC_PLATFORM_DIR)/files ]; then $(CP) $(GENERIC_PLATFORM_DIR)/files/* $(LINUX_DIR)/; fi
-       if [ -d ./files ]; then $(CP) ./files/* $(LINUX_DIR)/; fi
-       $(if $(strip $(QUILT)),$(call Quilt/Patch,$(GENERIC_PATCH_DIR),generic/), \
-               if [ -d $(GENERIC_PATCH_DIR) ]; then $(PATCH) $(LINUX_DIR) $(GENERIC_PATCH_DIR); fi \
-       )
-       $(if $(strip $(QUILT)),$(call Quilt/Patch,$(PATCH_DIR),platform/), \
-               if [ -d $(PATCH_DIR) ]; then $(PATCH) $(LINUX_DIR) $(PATCH_DIR); fi \
-       )
-       $(if $(strip $(QUILT)),touch $(PKG_BUILD_DIR)/.quilt_used)
+ifneq ($(HOST_BUILD_DIR),)
+  HOST_QUILT?=$(if $(findstring command,$(origin QUILT)),$(QUILT),$(if $(wildcard $(HOST_BUILD_DIR)/.quilt_used),y))
+  ifneq ($(HOST_QUILT),)
+    HOST_STAMP_CHECKED:=$(HOST_BUILD_DIR)/.quilt_checked
+    override CONFIG_AUTOREBUILD=
+    host-quilt-check: $(HOST_STAMP_CHECKED)
+  endif
+endif
+
+define Host/Patch/Default
+       $(if $(HOST_QUILT),rm -rf $(HOST_BUILD_DIR)/patches; mkdir -p $(HOST_BUILD_DIR)/patches)
+       $(call HostPatchDir,$(HOST_BUILD_DIR),$(HOST_PATCH_DIR),)
+       $(if $(HOST_QUILT),touch $(HOST_BUILD_DIR)/.quilt_used)
 endef
 
-$(STAMP_PATCHED): $(STAMP_PREPARED)
-       @cd $(PKG_BUILD_DIR); quilt pop -a -f >/dev/null 2>/dev/null || true
-       (\
-               cd $(PKG_BUILD_DIR)/patches; \
-               find * -type f \! -name series | sort > series; \
-       )
-       [ -f "$(PKG_BUILD_DIR)/patches/series" ] && cd $(PKG_BUILD_DIR); quilt push -a
-       touch $@
+define Build/Patch/Default
+       $(if $(QUILT),rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches)
+       $(call PatchDir,$(PKG_BUILD_DIR),$(PATCH_DIR),)
+       $(if $(QUILT),touch $(PKG_BUILD_DIR)/.quilt_used)
+endef
+
+kernel_files=$(foreach fdir,$(GENERIC_FILES_DIR) $(FILES_DIR),$(fdir)/.)
+define Kernel/Patch/Default
+       rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches
+       $(if $(kernel_files),$(CP) $(kernel_files) $(LINUX_DIR)/)
+       find $(LINUX_DIR)/ -name \*.rej -or -name \*.orig | $(XARGS) rm -f
+       $(call PatchDir,$(PKG_BUILD_DIR),$(GENERIC_PATCH_DIR),generic/)
+       $(call PatchDir,$(PKG_BUILD_DIR),$(PATCH_DIR),platform/)
+endef
 
 define Quilt/RefreshDir
-       mkdir -p $(1)
-       -rm -f $(1)/* 2>/dev/null >/dev/null
+       mkdir -p $(2)
+       -rm -f $(2)/* 2>/dev/null >/dev/null
        @( \
-               for patch in $$($(if $(2),grep "^$(2)",cat) $(PKG_BUILD_DIR)/patches/series | awk '{print $$1}'); do \
-                       $(CP) -v "$(PKG_BUILD_DIR)/patches/$$patch" $(1); \
+               for patch in $$$$($(if $(3),grep "^$(3)",cat) $(1)/patches/series | awk '{print $$$$1}'); do \
+                       $(CP) -v "$(1)/patches/$$$$patch" $(2); \
                done; \
        )
 endef
 
+define Quilt/Refresh/Host
+       $(call Quilt/RefreshDir,$(HOST_BUILD_DIR),$(PATCH_DIR))
+endef
+
 define Quilt/Refresh/Package
-       $(call Quilt/RefreshDir,$(PATCH_DIR))
+       $(call Quilt/RefreshDir,$(PKG_BUILD_DIR),$(PATCH_DIR))
 endef
 
 define Quilt/Refresh/Kernel
@@ -84,31 +120,50 @@ define Quilt/Refresh/Kernel
                echo "All kernel patches must start with either generic/ or platform/"; \
                false; \
        }
-       $(call Quilt/RefreshDir,$(GENERIC_PATCH_DIR),generic/)
-       $(call Quilt/RefreshDir,$(PATCH_DIR),platform/)
+       $(call Quilt/RefreshDir,$(PKG_BUILD_DIR),$(GENERIC_PATCH_DIR),generic/)
+       $(call Quilt/RefreshDir,$(PKG_BUILD_DIR),$(PATCH_DIR),platform/)
 endef
 
-quilt-check: $(STAMP_PREPARED) FORCE
-       @[ -f "$(PKG_BUILD_DIR)/.quilt_used" ] || { \
+define Quilt/Template
+  $($(2)STAMP_CONFIGURED): $($(2)STAMP_CHECKED) FORCE
+  $($(2)STAMP_CHECKED): $($(2)STAMP_PREPARED)
+       if [ -s "$(1)/patches/series" ]; then \
+               (cd "$(1)"; \
+                       if $(QUILT_CMD) next >/dev/null 2>&1; then \
+                               $(QUILT_CMD) push -a; \
+                       else \
+                               $(QUILT_CMD) top >/dev/null 2>&1; \
+                       fi \
+               ); \
+       fi
+       touch "$$@"
+
+  $(3)quilt-check: $($(2)STAMP_PREPARED) FORCE
+       @[ -f "$(1)/.quilt_used" ] || { \
                echo "The source directory was not unpacked using quilt. Please rebuild with QUILT=1"; \
                false; \
        }
-       @[ -f "$(PKG_BUILD_DIR)/patches/series" ] || { \
+       @[ -f "$(1)/patches/series" ] || { \
                echo "The source directory contains no quilt patches."; \
                false; \
        }
-       @[ "$$(cat $(PKG_BUILD_DIR)/patches/series | md5sum)" = "$$(sort $(PKG_BUILD_DIR)/patches/series | md5sum)" ] || { \
+       @[ -n "$$$$(ls $(1)/patches/series)" -o "$$$$(cat $(1)/patches/series | md5sum)" = "$$(sort $(1)/patches/series | md5sum)" ] || { \
                echo "The patches are not sorted in the right order. Please fix."; \
                false; \
        }
 
-refresh: quilt-check
-       @cd $(PKG_BUILD_DIR); quilt pop -a -f >/dev/null 2>/dev/null
-       @cd $(PKG_BUILD_DIR); while quilt next 2>/dev/null >/dev/null && quilt push; do \
-               quilt refresh; \
-       done; ! quilt next 2>/dev/null >/dev/null
-       $(if $(KERNEL_BUILD),$(Quilt/Refresh/Kernel),$(Quilt/Refresh/Package))
+  $(3)refresh: $(3)quilt-check
+       @cd "$(1)"; $(QUILT_CMD) pop -a -f >/dev/null 2>/dev/null
+       @cd "$(1)"; while $(QUILT_CMD) next 2>/dev/null >/dev/null && $(QUILT_CMD) push; do \
+               QUILT_DIFF_OPTS="-p" $(QUILT_CMD) refresh -p ab --no-index --no-timestamps; \
+       done; ! $(QUILT_CMD) next 2>/dev/null >/dev/null
+       $(Quilt/Refresh/$(4))
        
-update: quilt-check
-       $(if $(KERNEL_BUILD),$(Quilt/Refresh/Kernel),$(Quilt/Refresh/Package))
+  $(3)update: $(3)quilt-check
+       $(Quilt/Refresh/$(4))
+endef
+
+Build/Quilt=$(call Quilt/Template,$(PKG_BUILD_DIR),,,$(if $(TARGET_BUILD),Kernel,Package))
+Host/Quilt=$(call Quilt/Template,$(HOST_BUILD_DIR),HOST_,host-,Host)
 
+endif