tahvo doesn't need ohci
[openwrt/openwrt.git] / include / quilt.mk
index f5b852c3ce44e835a7f4f55882b08348efb52a90..9691dc3276c68dc8664ac38bd73d7c6afff1e628 100644 (file)
@@ -40,11 +40,12 @@ endef
 
 define PatchDir/Default
        @if [ -d "$(2)" -a "$$$$(ls $(2) | wc -l)" -gt 0 ]; then \
+               export PATCH="$(PATCH)"; \
                if [ -s "$(2)/series" ]; then \
                        $(call filter_series,$(2)/series) | xargs -n1 \
-                               $(PATCH) "$(1)" "$(2)"; \
+                               $(KPATCH) "$(1)" "$(2)"; \
                else \
-                       $(PATCH) "$(1)" "$(2)"; \
+                       $(KPATCH) "$(1)" "$(2)"; \
                fi; \
        fi
 endef
@@ -67,7 +68,7 @@ ifneq ($(PKG_BUILD_DIR),)
 endif
 
 ifneq ($(HOST_BUILD_DIR),)
-  HOST_QUILT?=$(if $(findstring command,$(origin $(QUILT))),$(QUILT),$(if $(wildcard $(HOST_BUILD_DIR)/.quilt_used),y))
+  HOST_QUILT?=$(if $(findstring command,$(origin QUILT)),$(QUILT),$(if $(wildcard $(HOST_BUILD_DIR)/.quilt_used),y))
   ifneq ($(HOST_QUILT),)
     HOST_STAMP_CHECKED:=$(HOST_BUILD_DIR)/.quilt_checked
     override CONFIG_AUTOREBUILD=
@@ -100,8 +101,8 @@ define Quilt/RefreshDir
        mkdir -p $(2)
        -rm -f $(2)/* 2>/dev/null >/dev/null
        @( \
-               for patch in $$$$($(if $(3),grep "^$(3)",cat) $(PKG_BUILD_DIR)/patches/series | awk '{print $$$$1}'); do \
-                       $(CP) -v "$(PKG_BUILD_DIR)/patches/$$$$patch" $(2); \
+               for patch in $$$$($(if $(3),grep "^$(3)",cat) $(1)/patches/series | awk '{print $$$$1}'); do \
+                       $(CP) -v "$(1)/patches/$$$$patch" $(2); \
                done; \
        )
 endef