fix spontaneous rebuilds caused by make package/<name>/update with quilt
[openwrt/openwrt.git] / include / quilt.mk
index e8c3b90a681d67647fb8794cfed2f02ed3dc4374..a7aac91c06cd230975655ef0869e258c46415d0d 100644 (file)
@@ -5,12 +5,17 @@
 # See /LICENSE for more information.
 #
 
-ifeq ($(KERNEL_BUILD),1)
+ifeq ($(TARGET_BUILD),1)
   PKG_BUILD_DIR:=$(LINUX_DIR)
 endif
+PATCH_DIR?=./patches
+
+ifeq ($(MAKECMDGOALS),refresh)
+  override QUILT=1
+endif
 
 define Quilt/Patch
-       @for patch in $$$$( (cd $(1) && ls) 2>/dev/null ); do ( \
+       @for patch in $$$$( (cd $(1) && if [ -f series ]; then grep -v '^#' series; else ls; fi; ) 2>/dev/null ); do ( \
                cp "$(1)/$$$$patch" $(PKG_BUILD_DIR); \
                cd $(PKG_BUILD_DIR); \
                quilt import -P$(2)$$$$patch -p 1 "$$$$patch"; \
@@ -21,23 +26,22 @@ endef
 
 QUILT?=$(strip $(shell test -f $(PKG_BUILD_DIR)/.quilt_used && echo y))
 ifneq ($(QUILT),)
-  STAMP_PREPARED:=$(strip $(STAMP_PREPARED))_q
   STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
-  CONFIG_AUTOREBUILD=
-  PATCHES:=$(shell )
+  override CONFIG_AUTOREBUILD=
   define Build/Patch/Default
        rm -rf $(PKG_BUILD_DIR)/patches
        mkdir -p $(PKG_BUILD_DIR)/patches
-       $(call Quilt/Patch,./patches,)
+       $(call Quilt/Patch,$(PATCH_DIR),)
        @echo
        touch $(PKG_BUILD_DIR)/.quilt_used
   endef
-  $(STAMP_CONFIGURED): $(STAMP_PATCHED)
+  $(STAMP_CONFIGURED): $(STAMP_PATCHED) FORCE
   prepare: $(STAMP_PATCHED)
+  quilt-check: $(STAMP_PATCHED)
 else
   define Build/Patch/Default
-       @if [ -d ./patches -a "$$$$(ls ./patches | wc -l)" -gt 0 ]; then \
-               $(PATCH) $(PKG_BUILD_DIR) ./patches; \
+       @if [ -d $(PATCH_DIR) -a "$$$$(ls $(PATCH_DIR) | wc -l)" -gt 0 ]; then \
+               $(PATCH) $(PKG_BUILD_DIR) $(PATCH_DIR); \
        fi
   endef
 endif
@@ -45,19 +49,43 @@ endif
 define Kernel/Patch/Default
        if [ -d $(GENERIC_PLATFORM_DIR)/files ]; then $(CP) $(GENERIC_PLATFORM_DIR)/files/* $(LINUX_DIR)/; fi
        if [ -d ./files ]; then $(CP) ./files/* $(LINUX_DIR)/; fi
-       $(if $(strip $(QUILT)),$(call Quilt/Patch,$(GENERIC_PLATFORM_DIR)/patches,generic/), \
-               if [ -d $(GENERIC_PLATFORM_DIR)/patches ]; then $(PATCH) $(LINUX_DIR) $(GENERIC_PLATFORM_DIR)/patches; fi \
+       $(if $(strip $(QUILT)),$(call Quilt/Patch,$(GENERIC_PATCH_DIR),generic/), \
+               if [ -d $(GENERIC_PATCH_DIR) ]; then $(PATCH) $(LINUX_DIR) $(GENERIC_PATCH_DIR); fi \
        )
-       $(if $(strip $(QUILT)),$(call Quilt/Patch,./patches,platform/), \
-               if [ -d ./patches ]; then $(PATCH) $(LINUX_DIR) ./patches; fi \
+       $(if $(strip $(QUILT)),$(call Quilt/Patch,$(PATCH_DIR),platform/), \
+               if [ -d $(PATCH_DIR) ]; then $(PATCH) $(LINUX_DIR) $(PATCH_DIR); fi \
        )
        $(if $(strip $(QUILT)),touch $(PKG_BUILD_DIR)/.quilt_used)
 endef
 
+ifeq ($(TARGET_BUILD),1)
+$(STAMP_PATCHED): $(STAMP_PREPARED)
+       @cd $(PKG_BUILD_DIR); quilt pop -a -f >/dev/null 2>/dev/null || true
+       (\
+               cd $(PKG_BUILD_DIR)/patches; \
+               rm -f series; \
+               for file in *; do \
+                       if [ -f $$file/series ]; then \
+                               echo "Converting $$file/series"; \
+                               awk -v file="$$file/" '$$0 !~ /^#/ { print file $$0 }' $$file/series >> series; \
+                       else \
+                               echo "Sorting patches in $$file"; \
+                               find $$file/* -type f \! -name series | sort >> series; \
+                       fi; \
+               done; \
+       )
+       if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt push -a); fi
+       touch $@
+else
 $(STAMP_PATCHED): $(STAMP_PREPARED)
        @cd $(PKG_BUILD_DIR); quilt pop -a -f >/dev/null 2>/dev/null || true
-       [ -f "$(PKG_BUILD_DIR)/patches/series" ] && cd $(PKG_BUILD_DIR); quilt push -a
+       (\
+               cd $(PKG_BUILD_DIR)/patches; \
+               find * -type f \! -name series | sort > series; \
+       )
+       if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt push -a); fi
        touch $@
+endif
 
 define Quilt/RefreshDir
        mkdir -p $(1)
@@ -70,7 +98,7 @@ define Quilt/RefreshDir
 endef
 
 define Quilt/Refresh/Package
-       $(call Quilt/RefreshDir,./patches)
+       $(call Quilt/RefreshDir,$(PATCH_DIR))
 endef
 
 define Quilt/Refresh/Kernel
@@ -78,11 +106,11 @@ define Quilt/Refresh/Kernel
                echo "All kernel patches must start with either generic/ or platform/"; \
                false; \
        }
-       $(call Quilt/RefreshDir,$(GENERIC_PLATFORM_DIR)/patches,generic/)
-       $(call Quilt/RefreshDir,./patches,platform/)
+       $(call Quilt/RefreshDir,$(GENERIC_PATCH_DIR),generic/)
+       $(call Quilt/RefreshDir,$(PATCH_DIR),platform/)
 endef
 
-refresh: $(STAMP_PREPARED)
+quilt-check: $(STAMP_PREPARED) FORCE
        @[ -f "$(PKG_BUILD_DIR)/.quilt_used" ] || { \
                echo "The source directory was not unpacked using quilt. Please rebuild with QUILT=1"; \
                false; \
@@ -95,5 +123,14 @@ refresh: $(STAMP_PREPARED)
                echo "The patches are not sorted in the right order. Please fix."; \
                false; \
        }
+
+refresh: quilt-check
+       @cd $(PKG_BUILD_DIR); quilt pop -a -f >/dev/null 2>/dev/null
+       @cd $(PKG_BUILD_DIR); while quilt next 2>/dev/null >/dev/null && quilt push; do \
+               quilt refresh; \
+       done; ! quilt next 2>/dev/null >/dev/null
+       $(if $(KERNEL_BUILD),$(Quilt/Refresh/Kernel),$(Quilt/Refresh/Package))
+       
+update: quilt-check
        $(if $(KERNEL_BUILD),$(Quilt/Refresh/Kernel),$(Quilt/Refresh/Package))