detect changes in package/kernel/modules/*.mk when scanning the package metadata
[openwrt/openwrt.git] / include / scan.mk
index ff23e0961ca24a53d51128b409f0ff46cfe77899..a7f74ecec8b637cfa46d8b3aed6d679497717984 100644 (file)
@@ -32,6 +32,11 @@ $(SCAN_STAMP):
        touch $@
 endif
 
        touch $@
 endif
 
+# FIXME: generate this dynamically?
+ifeq ($(SCAN_TARGET),pkginfo)
+tmp/info/.pkginfo-kernel: $(shell ls package/kernel/modules/*.mk)
+endif
+
 define scanfiles
 $(foreach FILE,$(SCAN),
   tmp/.$(SCAN_TARGET): tmp/info/.$(SCAN_TARGET)-$(FILE) FORCE
 define scanfiles
 $(foreach FILE,$(SCAN),
   tmp/.$(SCAN_TARGET): tmp/info/.$(SCAN_TARGET)-$(FILE) FORCE