acx fixes for 2.6.30
[openwrt/openwrt.git] / include / subdir.mk
index 26a86265247e92a1b7b741b19293278e2cb50831..3c1e3f9cae07814843e20c9ce4ecd69b7c899354 100644 (file)
@@ -5,7 +5,7 @@
 # See /LICENSE for more information.
 #
 
-SUBTARGETS:=clean download prepare compile install update refresh prereq
+SUBTARGETS:=clean download prepare compile install update refresh prereq dist distcheck
 
 subtarget-default = $(filter-out ., \
        $(if $($(1)/builddirs-$(2)),$($(1)/builddirs-$(2)), \
@@ -34,8 +34,8 @@ define subdir
         $(if $(call diralias,$(bd)),$(call warn_eval,$(1)/$(bd),l,T,$(1)/$(call diralias,$(bd))/$(btype)/$(target): $(1)/$(bd)/$(btype)/$(target)))
       )
       $(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $(if $(QUILT),,$($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd))))
-               $(if $(BUILD_LOG),@mkdir -p $(TOPDIR)/logs/$(1)/$(bd))
-               +$(if $(BUILD_LOG),set -o pipefail;) $$(SUBMAKE) -C $(1)/$(bd) $(target) $(if $(BUILD_LOG),SILENT= 2>&1 | tee $(TOPDIR)/logs/$(1)/$(bd)/$(target).txt) $(if $(findstring $(bd),$($(1)/builddirs-ignore-$(target))), || $(call MESSAGE,   ERROR: $(1)/$(bd) failed to build.))
+               $(if $(BUILD_LOG),@mkdir -p $(BUILD_LOG_DIR)/$(1)/$(bd))
+               +$(if $(BUILD_LOG),set -o pipefail;) $$(SUBMAKE) -C $(1)/$(bd) $(target) $(if $(BUILD_LOG),SILENT= 2>&1 | tee $(BUILD_LOG_DIR)/$(1)/$(bd)/$(target).txt) $(if $(findstring $(bd),$($(1)/builddirs-ignore-$(target))), || $(call MESSAGE,   ERROR: $(1)/$(bd) failed to build.))
         $$(if $(call debug,$(1)/$(bd),v),,.SILENT: $(1)/$(bd)/$(target))
 
       # legacy targets
@@ -47,9 +47,9 @@ define subdir
   $(foreach target,$(SUBTARGETS),$(call subtarget,$(1),$(target)))
 endef
 
-# Parameters: <subdir> <name> <target> <depends> <config options>
+# Parameters: <subdir> <name> <target> <depends> <config options> <stampfile location>
 define stampfile
-  $(1)/stamp-$(3):=$(STAGING_DIR)/stamp/.$(2)_$(3)$(if $(5),_$(call confvar,$(5)))
+  $(1)/stamp-$(3):=$(if $(6),$(6),$(STAGING_DIR))/stamp/.$(2)_$(3)$(if $(5),_$(call confvar,$(5)))
   $$($(1)/stamp-$(3)): $(TMP_DIR)/.build $(4)
        @+$(SCRIPT_DIR)/timestamp.pl -n $$($(1)/stamp-$(3)) $(1) $(4) || \
                $(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)