build: add support for packing version control downloads with xz
[openwrt/openwrt.git] / include / toplevel.mk
index 23d70ac81a1d3d092ab68bbc2a3aa16644d0241d..10b81049c5439b70d85b049d618096932f58fe27 100644 (file)
@@ -156,6 +156,15 @@ prereq:: prepare-tmpinfo .config
        @+$(MAKE) -r -s tmp/.prereq-build $(PREP_MK)
        @+$(NO_TRACE_MAKE) -r -s $@
 
+ifeq ($(SDK),1)
+
+%::
+       @+$(PREP_MK) $(NO_TRACE_MAKE) -r -s prereq
+       @./scripts/config/conf --defconfig=.config Config.in
+       @+$(ULIMIT_FIX) $(SUBMAKE) -r $@
+
+else
+
 %::
        @+$(PREP_MK) $(NO_TRACE_MAKE) -r -s prereq
        @( \
@@ -167,6 +176,8 @@ prereq:: prepare-tmpinfo .config
        )
        @+$(ULIMIT_FIX) $(SUBMAKE) -r $@
 
+endif
+
 help:
        cat README