build: fix symlinked .config handling
[openwrt/openwrt.git] / include / toplevel.mk
index 24e4ebf823fbb304fd32c67815596803890a367c..c90670bee62ee7912a1c08c2f582e6b0a074ceca 100644 (file)
@@ -126,7 +126,7 @@ menuconfig: scripts/config/mconf prepare-tmpinfo FORCE
        if [ \! -e .config -a -e $(HOME)/.openwrt/defconfig ]; then \
                cp $(HOME)/.openwrt/defconfig .config; \
        fi
-       $< Config.in
+       [ -L .config ] && export KCONFIG_OVERWRITECONFIG=1; $< Config.in
 
 prepare_kernel_conf: .config FORCE