add a crlf workaround similar to the one from freewrt
[openwrt/openwrt.git] / include / unpack.mk
index e533476b5276c1b8dd91ba5aae08e1426426ab43..7813e3b3d35683d18b4a7ad08e8a1410b448b055 100644 (file)
@@ -17,4 +17,7 @@ ifeq ($(strip $(PKG_UNPACK)),)
   else
     # try to autodetect file type
   endif
+  ifneq ($(strip $(CRLF_WORKAROUND)),)
+    PKG_UNPACK += && find $(PKG_BUILD_DIR) -type f -print0 | xargs -0 perl -pi -e 's!\r$$$$!!g'
+  endif
 endif